Bug 1251344 - [Docs] [Director] Section 3.7 of the RHELOSP7 Director Installation and Usage documentation
[Docs] [Director] Section 3.7 of the RHELOSP7 Director Installation and Usage...
Status: CLOSED DUPLICATE of bug 1242660
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
Director
Unspecified Linux
medium Severity medium
: z1
: Director
Assigned To: Dan Macpherson
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 00:20 EDT by Faiaz Ahmed
Modified: 2015-08-09 23:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-09 23:43:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Faiaz Ahmed 2015-08-07 00:20:00 EDT
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html-single/Director_Installation_and_Usage/index.html#sect-Configuring_the_Director


This command fails:
sudo semanage fcontext haproxy_t /etc/pki/instack-certs/*

with this outout:
usage: semanage [-h]
                
                {import,export,login,user,port,interface,module,node,fcontext,boolean,permissive,dontaudit}
                ...
semanage: error: unrecognized arguments: /etc/pki/instack-certs/undercloud.pem


SFDC case 01488857
Comment 3 Faiaz Ahmed 2015-08-07 00:23:28 EDT
SFDC case 1251344 have the same issue
Comment 4 Faiaz Ahmed 2015-08-07 00:24:10 EDT
(In reply to Faiaz Ahmed from comment #3)
> SFDC case 01488689 have the same issue
Comment 6 Andrew Dahms 2015-08-07 02:35:16 EDT
Assigning to Dan for review.
Comment 7 Eduardo Minguez 2015-08-07 04:06:47 EDT
It worked for me with the "-a -t" flags, like:

sudo semanage fcontext -a -t haproxy_exec_t /etc/pki/instack-certs/undercloud.pem
Comment 8 Dan Macpherson 2015-08-09 23:43:19 EDT
This BZ is a duplicate. Fix is currently being implemented. Should be available later today.

*** This bug has been marked as a duplicate of bug 1242660 ***

Note You need to log in before you can comment on or make changes to this bug.