Bug 1251406 - '-h' is missing in output of bash-completion for 'rhsm-debug system --'
'-h' is missing in output of bash-completion for 'rhsm-debug system --'
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 05:02 EDT by qianzhan
Modified: 2015-08-09 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-09 23:14:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description qianzhan 2015-08-07 05:02:33 EDT
Description of problem:
'-h' is missing in output of bash-completion for 'rhsm-debug system --'

Version-Release number of selected component (if applicable):
subscription-manager: 1.15.9-2.el7
python-rhsm: 1.15.4-2.el7


How reproducible:
always

Steps to Reproduce:
1. Check the '-h' options in help
[root@dhcp-128-89 ~]# rhsm-debug system --help
Usage: rhsm-debug system [OPTIONS] 

Assemble system information as a tar file or directory

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --destination=DESTINATION
                        the destination location of the result; default is
                        /tmp
  --no-archive          data will be in an uncompressed directory
  --sos                 only data not already included in sos report will be
                        collected
  --no-subscriptions    exclude subscription data (default)
  --subscriptions       include subscription data


2. Execute the bash-completion of 'rhsm-debug system -':
[root@dhcp-128-89 ~]# rhsm-debug system -
--destination       -h                  --help              --no-archive        --no-subscriptions  --proxy             --proxypassword     --proxyuser         --sos               --subscriptions  

3. Execute the bash-completion of 'rhsm-debug system --':
[root@dhcp-128-89 ~]# rhsm-debug system --
--destination       --help              --no-archive        --no-subscriptions  --proxy             --proxypassword     --proxyuser         --sos               --subscriptions



Actual results:
As step 3, '-h' option is missing in bash-completion of 'rhsm-debug system --'

Expected results:
The output of step 3 should be the same with that of step 2.

Additional info:
Comment 2 John Sefler 2015-08-07 08:44:58 EDT
(In reply to qianzhan from comment #0)

> 3. Execute the bash-completion of 'rhsm-debug system --':
> [root@dhcp-128-89 ~]# rhsm-debug system --
> --destination       --help              --no-archive       
> --no-subscriptions  --proxy             --proxypassword     --proxyuser     
> --sos               --subscriptions
> 
> 
> 
> Actual results:
> As step 3, '-h' option is missing in bash-completion of 'rhsm-debug system
> --'
> 
> Expected results:
> The output of step 3 should be the same with that of step 2.
> 


I disagree with these expected results.  Since you typed two dashes, the bash completion should *not* match option "-h" since there is only one dash in the option.  "--" does not match the leading characters in option "-h".

My vote is to move to CLOSED NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.