Bug 125143 - 2.6.6-1.411 kernel BUG while starting X
2.6.6-1.411 kernel BUG while starting X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 125189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 22:30 EDT by Matthew Gregan [:kinetik]
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 06:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete output of: cpuinfo dmesg interrupts lsmod lspci-vv meminfo Xorg.0.log (12.71 KB, application/octet-stream)
2004-06-02 22:39 EDT, Matthew Gregan [:kinetik]
no flags Details

  None (edit)
Description Matthew Gregan [:kinetik] 2004-06-02 22:30:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040406 Firefox/0.8.0+

Description of problem:
Upgraded to kernel 2.6.6-1.411 from Arjan's repository at
http://people.redhat.com/arjanv/2.6 using yum.  Rebooted, and the
system appears to hang with a blank screen after X starts and takes
over the console.  Attempting to switch virtual consoles does not
work, but Ctrl-Alt-Del will reboot the box.

As machine is still responding to network connections, I was able to
ssh in and work out what the problem was.


ps alxw shows:
F   UID   PID  PPID PRI  NI   VSZ  RSS WCHAN  STAT TTY        TIME COMMAND
4     0  2895  2874  18   0 19544 8676 -      D    ?          0:00
/usr/X11R6/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt8


The last entries in /var/log/Xorg.0.log are:
(II) Setting vga for screen 0.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib64/modules/linux/libint10.a
(II) Module int10: vendor="X.Org Foundation"
        compiled for 6.7.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.7
(II) NV(0): Initializing int10


dmesg reveals a kernel BUG message:
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at shmem:614
invalid operand: 0000 [1]
CPU 0
Modules linked in: ipv6 parport_pc lp parport autofs4 ds yenta_socket
pcmcia_core sunrpc ipt_REJECT ipt_state ip_conntrack iptable_filter
ip_tables floppy sg forcedeth joydev ohci_hcd ehci_hcd button battery
asus_acpi ac xfs raid1 dm_mod sata_sil libata sd_mod scsi_mod
Pid: 2840, comm: X Not tainted 2.6.6-1.411
RIP: 0010:[<ffffffff801571ba>] <ffffffff801571ba>{shmem_delete_inode+137}
RSP: 0018:0000010035821ca8  EFLAGS: 00010202
RAX: 000001003fd95b00 RBX: 000001003fd959f8 RCX: 0000000000000000
RDX: 0000000000000000 RSI: 0000000000000000 RDI: 000001003fd959f8
RBP: 0000010001f1f378 R08: 0000000000000000 R09: 0000000000000000
R10: 0000000000000000 R11: 0000000000000000 R12: 000001003fd959f8
R13: 0000010035292468 R14: ffffffff80436810 R15: 0000000000000000
FS:  0000002a95d860a0(0000) GS:ffffffff80460100(0000)
knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000e6b018 CR3: 0000000000101000 CR4: 00000000000006e0
Process X (pid: 2840, threadinfo 0000010035820000, task 000001003615e800)
Stack: 0000000000000000 000001003fd959f8 ffffffff80157131 ffffffff80172662
       ffffffff801725b0 000001003fd959f8 000001003ffbc500 ffffffff80172831
       0000010035292468 ffffffff8017022d
Call Trace:<ffffffff80157131>{shmem_delete_inode+0}
<ffffffff80172662>{generic_delete_inode+178}
       <ffffffff801725b0>{generic_delete_inode+0}
<ffffffff80172831>{iput+110}
       <ffffffff8017022d>{dput+354} <ffffffff8015e76e>{__fput+212}
       <ffffffff801a064b>{shm_destroy+77}
<ffffffff801a0fe6>{sys_shmctl+1229}
       <ffffffff80149786>{__set_page_dirty_nobuffers+263}
       <ffffffff8015065d>{zap_pte_range+552}
<ffffffff80150762>{zap_pmd_range+181}
       <ffffffff801507d7>{unmap_page_range+80}
<ffffffff80150918>{unmap_vmas+284}
       <ffffffff80153f73>{unmap_vma+159}
<ffffffff80153f87>{unmap_vma_list+18}
       <ffffffff80154302>{do_munmap+320}
<ffffffff80111092>{system_call+126}


Code: 0f 0b 44 4e 2d 80 ff ff ff ff 66 02 48 ff 45 18 48 89 df 41
RIP <ffffffff801571ba>{shmem_delete_inode+137} RSP <0000010035821ca8>


lsmod:
Module                  Size  Used by
ipv6                  249856  14
parport_pc             25536  1
lp                     11512  0
parport                40460  2 parport_pc,lp
autofs4                18568  0
ds                     16904  0
yenta_socket           20096  0
pcmcia_core            57616  2 ds,yenta_socket
sunrpc                146680  1
ipt_REJECT              5888  1
ipt_state               2048  2
ip_conntrack           33692  1 ipt_state
iptable_filter          2688  1
ip_tables              16640  3 ipt_REJECT,ipt_state,iptable_filter
floppy                 61808  0
sg                     37944  0
forcedeth              14592  0
joydev                  9216  0
ohci_hcd               20880  0
ehci_hcd               31492  0
button                  6312  0
battery                 9104  0
asus_acpi              12704  0
ac                      4496  0
xfs                   547432  1
raid1                  13696  1
dm_mod                 42784  3
sata_sil                6660  4
libata                 38792  1 sata_sil
sd_mod                 19456  6
scsi_mod              122144  3 sg,libata,sd_mod


cat /proc/interrupts
           CPU0
  0:    5796926          XT-PIC  timer
  1:       1112          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  5:         49          XT-PIC  ehci_hcd, ohci_hcd, ohci_hcd
  8:          0          XT-PIC  rtc
  9:          0          XT-PIC  acpi
 10:      68732          XT-PIC  libata
 12:     576398          XT-PIC  eth0
 15:        501          XT-PIC  ide1
NMI:        245
LOC:    5795953
ERR:          0
MIS:          0


Version-Release number of selected component (if applicable):
kernel-2.6.6-1.411

How reproducible:
Always

Steps to Reproduce:
1.  Install kernel-2.6.6-1.411.x86_64.
2.  Boot new kernel.
3.  Start X.
    

Actual Results:  X takes over the console, displays a blank screen,
and appears to hang.  ps reveals X in D state.  dmesg reveals kernel
BUG during X initialisation.

Additional info:
Comment 1 Matthew Gregan [:kinetik] 2004-06-02 22:39:10 EDT
Created attachment 100814 [details]
Complete output of: cpuinfo  dmesg  interrupts lsmod  lspci-vv  meminfo  Xorg.0.log
Comment 2 Matthew Gregan [:kinetik] 2004-06-02 22:46:55 EDT
CPU: Opteron 146
Memory: 2x 512MB DDR333
Motherboard: Leadtek KN8NFX (BIOS: 2004/1/8)
Video card: Albatron NVIDIA GeForce FX 5700 Ultra

Also worth noting is that X runs fine with the 2.6.5-1.358.x86_64
kernel that was provided with the FC2 release.  I upgraded to the
2.6.6-1.411.x86_64 kernel because of problems with the sata_sil driver
and my Silicon Image SiI 3114 SATA controller.
Comment 3 Arjan van de Ven 2004-06-03 03:41:14 EDT
the good news is that I can reproduce this bug, the bad news is that I
haven't found the  bug in the first 5 minutes ;) 
looking deeper
Comment 4 Brian Millett 2004-06-03 11:06:49 EDT
*** Bug 125189 has been marked as a duplicate of this bug. ***
Comment 5 Brian Millett 2004-06-03 11:59:37 EDT
Ok, the 414 build works for me.
Thanks.
Comment 6 Matthew Gregan [:kinetik] 2004-06-03 19:21:31 EDT
The 414 build also works for me.

Note You need to log in before you can comment on or make changes to this bug.