Bug 1251444 - log viewer error message contains html tags
log viewer error message contains html tags
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-access-plugin-rhsc (Show other bugs)
3.1
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Sahina Bose
RHS-C QE
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 06:02 EDT by Martin Kudlej
Modified: 2016-03-23 02:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 02:23:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log message with html tags (139.87 KB, image/png)
2015-08-07 06:08 EDT, Martin Kudlej
no flags Details

  None (edit)
Description Martin Kudlej 2015-08-07 06:02:06 EDT
Description of problem:
Log viewer contains error message with html tags:
"<html><head><title>JBoss Web/7.5.9.Final-redhat-1 - JBWEB000064: Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>JBWEB000065: HTTP Status 500 - </h1><HR size="1" noshade="noshade"><p><b>JBWEB000309: type</b> JBWEB000066: Exception report</p><p><b>JBWEB000068: message</b> <u></u></p><p><b>JBWEB000069: description</b> <u>JBWEB000145: The server encountered an internal error that prevented it from fulfilling this request.</u></p><p><b>JBWEB000070: exception</b> <pre>java.lang.IllegalStateException org.apache.catalina.connector.ResponseFacade.sendError(ResponseFacade.java:392) com.redhat.gss.redhat_access_plugin.server.Logs.doGet(Logs.java:59) javax.servlet.http.HttpServlet.service(HttpServlet.java:734) javax.servlet.http.HttpServlet.service(HttpServlet.java:847) </pre></p><p><b>JBWEB000072: note</b> <u>JBWEB000073: The full stack trace of the root cause is available in the JBoss Web/7.5.9.Final-redhat-1 logs.</u></p><HR size="1" noshade="noshade"><h3>JBoss Web/7.5.9.Final-redhat-1</h3></body></html>"

Version-Release number of selected component (if applicable):
gluster-nagios-common-0.2.0-1.el6rhs.noarch
redhat-access-plugin-rhsc-3.0.0-3.el6rhs.noarch
rhsc-3.1.0-0.62.el6.noarch
rhsc-backend-3.1.0-0.62.el6.noarch
rhsc-branding-rhs-3.1.0-1.el6rhs.noarch
rhsc-cli-3.0.0.0-0.2.el6rhs.noarch
rhsc-dbscripts-3.1.0-0.62.el6.noarch
rhsc-doc-3.1.0-1.el6eng.noarch
rhsc-extensions-api-impl-3.1.0-0.62.el6.noarch
rhsc-lib-3.1.0-0.62.el6.noarch
rhsc-log-collector-3.1.0-1.0.el6rhs.noarch
rhsc-monitoring-uiplugin-0.2.3-1.el6rhs.noarch
rhsc-restapi-3.1.0-0.62.el6.noarch
rhsc-sdk-python-3.0.0.0-0.2.el6rhs.noarch
rhsc-setup-3.1.0-0.62.el6.noarch
rhsc-setup-base-3.1.0-0.62.el6.noarch
rhsc-setup-plugin-ovirt-engine-3.1.0-0.62.el6.noarch
rhsc-setup-plugin-ovirt-engine-common-3.1.0-0.62.el6.noarch
rhsc-setup-plugins-3.1.0-3.el6rhs.noarch
rhsc-tools-3.1.0-0.62.el6.noarch
rhsc-webadmin-portal-3.1.0-0.62.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1. install RHSC
2. try to add host which is not registered to cdn or rhn
3. look into log viewer on logs from this host

Actual results:
It shows error message with html tags.

Expected results:
It will display error message without html tags but with proper formatting.
Comment 2 Martin Kudlej 2015-08-07 06:08:02 EDT
Created attachment 1060322 [details]
log message with html tags
Comment 5 Sahina Bose 2016-03-23 02:23:50 EDT
As per the bug 1290720 - redhat-access-plugin will no longer be supported in RHGS-C. Hence closing this bug

Note You need to log in before you can comment on or make changes to this bug.