This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251587 - Clean up of spec file.
Clean up of spec file.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: patchutils (Show other bugs)
rawhide
All All
unspecified Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 15:58 EDT by Sergio Monteiro Basto
Modified: 2015-08-24 04:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: patchutils-0.3.4-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-23 21:26:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Clean up spec files (1.15 KB, patch)
2015-08-07 15:58 EDT, Sergio Monteiro Basto
no flags Details | Diff
fedora_review.patch (953 bytes, patch)
2015-08-09 12:48 EDT, Sergio Monteiro Basto
no flags Details | Diff
fix FTBFS on epel6 (430 bytes, patch)
2015-08-19 19:55 EDT, Sergio Monteiro Basto
no flags Details | Diff

  None (edit)
Description Sergio Monteiro Basto 2015-08-07 15:58:49 EDT
Created attachment 1060474 [details]
Clean up spec files

Hi , 

I thought the best way was report here, small cleaning that can be made in patchutils.spec file


Version-Release number of selected component (if applicable):

patchutils-0.3.4-2.fc21.x86_64
Comment 1 Sergio Monteiro Basto 2015-08-09 12:48:23 EDT
Created attachment 1060776 [details]
fedora_review.patch

Running fedora-review -n ./ , we may fix 3 minor issues in patchutils.spec 

if Obsoletes: interdiff <= 0.0.10
we should provide a bigger version ... 

Added %license tag

and
-make %{?smp_mflags}
+make %{?_smp_mflags}
Comment 2 Sergio Monteiro Basto 2015-08-19 19:55:29 EDT
Created attachment 1065041 [details]
fix FTBFS on epel6

Hello , 
one little fix for epel6 and I tried aldo build on epel5 but doesn't build because tar doesn't support xz compression [1] ...

[1] 
https://copr-be.cloud.fedoraproject.org/results/sergiomb/patchutils_with_diffview/epel-5-x86_64/00108112-patchutils/build.log.gz

from 

https://copr.fedoraproject.org/coprs/sergiomb/patchutils_with_diffview/build/108112/
Comment 3 Sergio Monteiro Basto 2015-08-23 21:26:13 EDT
The patches are committed [1] , we may close this report. 

Thanks, 

[1] http://pkgs.fedoraproject.org/cgit/patchutils.git/commit/?id=dd2c8dc409bf9e95d55000ca409fa91a4418eb60

Note You need to log in before you can comment on or make changes to this bug.