This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251694 - Screen flickering and corruption on Intel G41 after xorg-x11-drv-intel update
Screen flickering and corruption on Intel G41 after xorg-x11-drv-intel update
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
7.1
x86_64 Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Lyude
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 16:36 EDT by rudolf
Modified: 2016-04-28 18:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-28 18:07:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshw (528 bytes, text/plain)
2015-08-08 16:38 EDT, rudolf
no flags Details

  None (edit)
Description rudolf 2015-08-08 16:36:33 EDT
Description of problem:

Screen flickers after update to latest xorg-x11-drv-intel.
It happens when clicking on top menu in Gnome Classic, and it looks like big black triangle or rectangle shaped artifact, usualy on top half of screen and different size every time. In worst cases whole screen turns blue.

Version-Release number of selected component (if applicable):
2.99.916-5


Additional info:

Happens on clean 7.1 installation, not on 7.0 with driver version 2.21.15-13.
Sometimes imposible to reproduce. Hardware is most likely OK, never happened to me on different distributions with gnome 3.

Nothing unusual in logs, KDE doesnt seem to be affected.
Comment 1 rudolf 2015-08-08 16:38:18 EDT
Created attachment 1060659 [details]
lshw
Comment 3 rudolf 2015-08-18 08:36:35 EDT
I can confirm this issue exists also on HP Elite 8000 with Intel Q45 chipset.
Both G41 and Q45 have integrated VGA Intel GMA 4500
Comment 4 rudolf 2015-08-23 12:40:30 EDT
I did some testing and problem disappears if I use UXA acceleration, or SNA acceleration combined with TearFree.

so these configurations work for me:

cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "sna"
   Option      "TearFree"    "true"
EndSection


or..

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "uxa"
EndSection
Comment 5 rudolf 2015-09-13 05:31:05 EDT
This problem is not present in 7.2 beta

Note You need to log in before you can comment on or make changes to this bug.