Bug 1251696 - gem freezing during installing packages
gem freezing during installing packages
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rubygems (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vít Ondruch
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 17:47 EDT by Levent Yalcin
Modified: 2015-08-10 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 08:49:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levent Yalcin 2015-08-08 17:47:42 EDT
Description of problem:
rubygems package comes with 1.3.7 which is no longer supported. Here is the issue https://github.com/rubygems/rubygems/issues/1022 

How reproducible:
If you try to install any package by gem it's just freezing.

Steps to Reproduce:
1. gem install somepackage
2. strace -p $(ps aux | grep 'gem install' | grep -v grep | awk '{print $2}')
Comment 2 Vít Ondruch 2015-08-10 08:49:00 EDT
Hi Levent,

Sorry, but I cannot reproduce this:

# time gem install rails
ERROR:  Error installing rails:
	i18n requires Ruby version >= 1.9.3.

real	3m39.922s
user	1m44.021s
sys	0m41.955s

IOW, if I take the example from gh#1022, it definitely takes ages and at the end fails, but otherwise everything looks OK. You should try the "gem install -V rails" as suggested in the upstream ticket to reduce your boredom during wait :)

And yes, I can see the same strace output as mentioned in GH ticket.
Comment 3 Levent Yalcin 2015-08-10 12:32:48 EDT
Hi Vit, 

Well, I could install rake for example in 20 minutes. I'm trying to install puppet which can work with Ruby 1.8.x. So, I started to install it at 13:38 UTC and still going. btw, It is 17:21.

[root@localhost ~]# date && gem install puppet -v 3.4.0 && date
Mon Aug 10 13:38:16 UTC 2015
Successfully installed facter-1.7.6
Successfully installed json_pure-1.8.2
Successfully installed hiera-1.3.4
Successfully installed rgen-0.6.6
Successfully installed puppet-3.4.0
5 gems installed
Installing ri documentation for facter-1.7.6...
Installing ri documentation for json_pure-1.8.2...
Installing ri documentation for hiera-1.3.4...
Installing ri documentation for rgen-0.6.6...
Installing ri documentation for puppet-3.4.0...

It doesn't seem gem works or reasonable imho. 

So, I can bake some AMIs and can manage it. I just mean it's good to have working version of it if there is an RPM package.

*:
yum install -y ruby-devel rubygems git
gem list rubygems-update -i || gem install --no-ri --no-rdoc rubygems-update
[ "$(gem -v)" != "1.3.7" ] || update_rubygems
Comment 4 Vít Ondruch 2015-08-10 12:50:25 EDT
Well, RubyGems certainly used to work faster. From the verbose output, I'd say that the rubygems.org probably changed the way how the metadata about packages are provided, since it seems to download a lot of small files where it used to download one archive (if I am not mistaken). One thing which could help is rebase, but there are just small chances to get this approved in this stage of RHEL6 lifecycle. Nevertheless, please don't hesitate to contact Red Hat support and escalate the issue that way.
Comment 5 Vít Ondruch 2015-08-10 13:03:08 EDT
(In reply to Levent Yalcin from comment #3)
> Well, I could install rake for example in 20 minutes.

BTW installation of Rake takes seconds:

# date && gem install rake && date
Mon Aug 10 19:02:35 CEST 2015
Successfully installed rake-10.4.2
1 gem installed
Installing ri documentation for rake-10.4.2...
Installing RDoc documentation for rake-10.4.2...
Mon Aug 10 19:02:45 CEST 2015

Note You need to log in before you can comment on or make changes to this bug.