Bug 1251729 - no boto section during keystone authentication in openstack certification gui
no boto section during keystone authentication in openstack certification gui
Status: CLOSED NOTABUG
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-openstack (Show other bugs)
1.0
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rohan Kanade
Anshul Behl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-09 05:41 EDT by Lenny Verkhovsky
Modified: 2015-08-13 09:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 09:47:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (3.66 KB, application/x-gzip)
2015-08-09 05:41 EDT, Lenny Verkhovsky
no flags Details
screenshot (80.51 KB, image/jpeg)
2015-08-10 10:19 EDT, Lenny Verkhovsky
no flags Details

  None (edit)
Description Lenny Verkhovsky 2015-08-09 05:41:50 EDT
Created attachment 1060718 [details]
logs

Description of problem:
Cannot run tests from the GUI


Version-Release number of selected component (if applicable):
openstack-tempest-kilo-20150708.2.el7.noarch
redhat-certification-1.0-20150723.el7.noarch

How reproducible:
try to follow https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform_Certification_Test_Suite/6/html/User_Guide/chap-Certification_Workflow.html
3.1.11 step fails


Actual results:
No section: 'boto'

Expected results:
getting plugin selection

Additional info:

local variable 'subnet' referenced before assignment
response: http://10.209.37.34:5000/v2.0
response: admin
response: admin
Configuring tempest
Error while generating Tempest configuration, Please check keystone credentials
No section: 'boto'
Comment 1 Rohan Kanade 2015-08-10 05:21:02 EDT
Version-Release number of selected component (if applicable):
openstack-tempest-kilo-20150708.2.el7.noarch
redhat-certification-1.0-20150723.el7.noarch


Above packages are not to be used when certifying for RHELOSP 6

Please follow 2.1.7 in below link to install correct packages[0] and try to run the test suite.


[0]: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform_Certification_Test_Suite/6/html/User_Guide/chap-Certification_Requirements.html
Comment 2 Lenny Verkhovsky 2015-08-10 10:19:55 EDT
Created attachment 1061113 [details]
screenshot

thanks.
I've followed the steps and installed the packages.

I answer all the question and submitted for a run in GUI.

It runs a lot of tempest and after a while show the screen attached.
If I enter the keystone URL I need to go over all configuration again in the loop.

full rhoscts logs are located here due to a big size http://144.76.193.39/tmp/rhoscts-network20150810.tgz
Comment 3 Rohan Kanade 2015-08-11 03:27:53 EDT
I can see from the attached screenshot that you have test results that are complete but "not submitted"

Please follow below guide to submit results to Red Hat

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform_Certification_Test_Suite/6/html/User_Guide/chap-Certification_Workflow.html#Submit_the_Test_Logs_for_Review_and_Interpret_Test_Results
Comment 4 Lenny Verkhovsky 2015-08-13 09:47:13 EDT
thanks for the assistance.
BTW, the latest 
redhat-certification-openstack-1.0.5-1.el7.noarch.rpm
installs tempest-kilo



#yum install /.autodirect/mtrswgwork/lennyb/work/CloudX/ROS/redhat-certification-openstack-1.0.5-1.el7.noarch.rpm
Installing:
redhat-certification-openstack                    noarch                    1.0.5-1.el7                                 /redhat-certification-openstack-1.0.5-1.el7.noarch                     98 k
Installing for dependencies:
openstack-tempest                                 noarch                    1:kilo-20150708.2.el7                       openstack-kilo                                                        1.3 M



yum install /.autodirect/mtrswgwork/lennyb/work/CloudX/ROS/redhat-certification-openstack-1.0.0-1.el7.noarch.rpm
Installing:
redhat-certification-openstack                       noarch                       1.0.0-1.el7                        /redhat-certification-openstack-1.0.0-1.el7.noarch                        74 k

Note You need to log in before you can comment on or make changes to this bug.