Bug 1251731 - [abrt] meld: subprocess.py:1335:_execute_child:OSError: [Errno 2] No such file or directory: '/home/other/workspace/git-hub/ssabchew/srvconfig/sty-etc/scripts/-'
[abrt] meld: subprocess.py:1335:_execute_child:OSError: [Errno 2] No such fil...
Status: CLOSED DUPLICATE of bug 1253516
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6a2c64773e6a5ff47a66605921f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-09 06:55 EDT by ssabchew
Modified: 2015-09-10 07:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 17:30:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.72 KB, text/plain)
2015-08-09 06:55 EDT, ssabchew
no flags Details
File: environ (4.41 KB, text/plain)
2015-08-09 06:55 EDT, ssabchew
no flags Details

  None (edit)
Description ssabchew 2015-08-09 06:55:07 EDT
Description of problem:
I tried to use it as passing diff from git:
git diff .  | meld -

Version-Release number of selected component:
meld-3.14.0-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /usr/bin/meld -
dso_list:       python-libs-2.7.10-4.fc22.x86_64
executable:     /usr/bin/meld
kernel:         4.1.3-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
subprocess.py:1335:_execute_child:OSError: [Errno 2] No such file or directory: '/home/other/workspace/git-hub/ssabchew/srvconfig/sty-etc/scripts/-'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 72, in do_command_line
    tab = self.parse_args(command_line)
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 328, in parse_args
    focus=i == 0)
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 147, in open_files
    return window.open_paths(paths, **kwargs)
  File "/usr/lib/python2.7/site-packages/meld/meldwindow.py", line 727, in open_paths
    tab = self.append_vcview(a, auto_compare)
  File "/usr/lib/python2.7/site-packages/meld/meldwindow.py", line 686, in append_vcview
    doc.set_location(location)
  File "/usr/lib/python2.7/site-packages/meld/vcview.py", line 389, in set_location
    self.choose_vc(location)
  File "/usr/lib/python2.7/site-packages/meld/vcview.py", line 337, in choose_vc
    elif not avc.valid_repo(location):
  File "/usr/lib/python2.7/site-packages/meld/vc/git.py", line 268, in valid_repo
    return not _vc.call([cls.CMD, "branch"], cwd=path)
  File "/usr/lib/python2.7/site-packages/meld/vc/_vc.py", line 351, in call
    return subprocess.call(cmd, cwd=cwd, stdout=NULL, stderr=NULL)
  File "/usr/lib64/python2.7/subprocess.py", line 522, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory: '/home/other/workspace/git-hub/ssabchew/srvconfig/sty-etc/scripts/-'

Local variables in innermost frame:
errread: None
c2pread: None
gc_was_enabled: True
errwrite: 17
shell: False
errpipe_write: 18
to_close: set([])
close_fds: False
self: <subprocess.Popen object at 0x7f71a76097d0>
env: None
cwd: '/home/other/workspace/git-hub/ssabchew/srvconfig/sty-etc/scripts/-'
child_exception: OSError(2, 'No such file or directory')
args: ['git', 'branch']
executable: 'git'
c2pwrite: 17
data: 'cexceptions\nOSError\np0\n(I2\nS\'No such file or directory\'\np1\nS\'/home/other/workspace/git-hub/ssabchew/srvconfig/sty-etc/scripts/-\'\np2\ntp3\nRp4\n(dp5\nS\'child_traceback\'\np6\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1279, in _execute_child\\n    os.chdir(cwd)\\nOSError: [Errno 2] No such file or directory: \\\'/home/other/workspace/git-hub/ssabchew/srvconfig/sty-etc/scripts/-\\\'\\n\'\np7\nsb.'
creationflags: 0
errpipe_read: 16
preexec_fn: None
p2cread: None
startupinfo: None
p2cwrite: None
_close_in_parent: <function _close_in_parent at 0x7f71a75fe938>
universal_newlines: False
Comment 1 ssabchew 2015-08-09 06:55:11 EDT
Created attachment 1060720 [details]
File: backtrace
Comment 2 ssabchew 2015-08-09 06:55:12 EDT
Created attachment 1060721 [details]
File: environ
Comment 3 Dominic Hopf 2015-09-08 17:30:06 EDT

*** This bug has been marked as a duplicate of bug 1253516 ***

Note You need to log in before you can comment on or make changes to this bug.