Bug 125177 - Boot fails to look up internet address dhcppc2
Boot fails to look up internet address dhcppc2
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2004-06-03 09:18 EDT by Dale Kerby
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-07 13:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dale Kerby 2004-06-03 09:18:58 EDT
Description of problem:
When booting I get the following message:

could not look up internet address for dhcppc2.  This will prevent
GNOME from operating properly.  It may be possible to correct the
problem by adding dhcppc2 to the file /etc/hosts.

Tried the foregoing - did not help

Version-Release number of selected component (if applicable):

How reproducible:
Every bootup

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Bill Nottingham 2004-06-03 12:49:13 EDT
What's your /etc/sysconfig/network, /etc/resolv.conf, and the output of:

ip addr ls
ip route ls

Comment 2 Dale Kerby 2004-06-03 20:42:22 EDT

; generated by /sbin/dhclient-script
search home

ip addr ls:
bash: ip: command not found

id route ls:
bash: ip: command not found
Comment 3 Bill Nottingham 2004-06-03 21:49:14 EDT

/sbin/ip addr ls
/sbin/ip route ls
Comment 4 Dale Kerby 2004-06-04 06:00:24 EDT
/sbin/ip addr ls:
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: sit0: <NOARP> mtu 1480 qdisc noop
    link/sit brd
4: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:09:5b:1f:52:dd brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
    inet6 fe80::209:5bff:fe1f:52dd/64 scope link
       valid_lft forever preferred_lft forever

/sbin/ip route ls: dev eth0  proto kernel  scope link  src dev eth0  scope link dev lo  scope link
default via dev eth0

Comment 5 Bill Nottingham 2004-06-04 16:23:20 EDT
Are you running your own name/dhcp server?
Comment 6 Dale Kerby 2004-06-04 23:25:02 EDT
I may be (newbie) but it was what was setup during installation, in
other words not intentional.
Comment 7 Bill Nottingham 2004-06-07 11:06:27 EDT
Setup during installation... of the OS? Of your internet link? 

How are you connected to the network?
Comment 8 Dale Kerby 2004-06-07 12:04:05 EDT
Of the OS.  We have (had) a windows network with three nodes.  We
connect to the internet through a router and cable modem.  The other
nodes are another desktop machine and a laptop.  I would like to
completely change over to Linux, however.
Comment 9 Bill Nottingham 2004-06-07 12:07:38 EDT is your router box?
Comment 10 Dale Kerby 2004-06-07 13:03:05 EDT
Router box:
Default gateway:
Comment 11 Bill Nottingham 2004-06-07 13:54:14 EDT
OK, it looks like your DHCP server (whatever it is) is handing out
hostnames (dhcppc2) that your DNS server ( can't resolve.

The configuration really needs to be fixed on that end.
Comment 12 Dale Kerby 2004-06-12 19:50:05 EDT
I'm sorry to 'bug' you, but can you tell me what the configuration
should look like.  I've spent some time looking into the matter and
cannot determine what needs to be done.  Thank you, in advance.
Comment 13 Bill Nottingham 2004-06-28 17:26:36 EDT
Basically, whatever hostnames your DHCP server sends out to the client
(dhcppc2) needs to have an entry in the 'home' domain of your DNS server.
Comment 14 james kellndorfer 2004-07-28 18:47:22 EDT
FC2 - 2.6.6-1.435.2 Desktop installation.
I too have the same error message. As an infant newbie, it would be
great if some of these bug reports and other FAQs include an
explanation of how these messages are generated. These explanations
would go a long way to help develop a diagnostic flow chart.

In addition, I didn't see any clarification of the etc/hosts.

1. what is etc/hosts? What actions should I take?
2. as was alluded to above, what are the normal settings?
3. why is the message being generated?
4. what module or process is responisble for creating this warning?
Comment 15 Bill Nottingham 2004-07-28 20:46:18 EDT
1. /etc/hosts is a networking configuration file that matches host
names to IP addresses. Google or some other reference may help more here.

2. A proper /etc/hosts looks something like:

# Do not remove the following line, or various programs
# that require network functionality will fail.               localhost.localdomain localhost

The lines starting with '#' are comments.

3. The message is being generated because the hostname that your
machine has (dhcppc2, in the above case) does not resolve; the
computer can't map that hostname to an IP address.

4. The message comes from early in the startup of the GNOME desktop;
it checks this because things do *not* work properly if the machine's
host name doesn't resolve.

A potential fix, if your hostname is *constant*, is to add it to the
end of the line in /etc/hosts.

Note You need to log in before you can comment on or make changes to this bug.