Bug 1251786 - Deleting a content view doesn't delete published content
Deleting a content view doesn't delete published content
Status: CLOSED DUPLICATE of bug 1265703
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.0.1
All Linux
medium Severity medium (vote)
: Unspecified
: 6.1
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-09 20:17 EDT by Anand Vaddarapu
Modified: 2015-12-03 10:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 12:01:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Vaddarapu 2015-08-09 20:17:23 EDT
Description of problem:
It seems that Satellite doesn't clean up published content for content views that have been deleted. Tried deleting from

/var/lib/pulp/published/yum/ 
/var/lib/pulp/nodes/published 
/etc/puppet/environments/ 

but still appear in the GUI. 

classes in the web UI at Configure > Puppet classes  delete them by clicking the "Delete" link in the right-most column solves the probelm.

Expected Results:
When we delete content view it should remove all references to it.
Comment 2 Brad Buckingham 2015-10-26 12:01:27 EDT

*** This bug has been marked as a duplicate of bug 1265703 ***

Note You need to log in before you can comment on or make changes to this bug.