Bug 1251795 - [abrt] epiphany-runtime: g_type_check_instance(): epiphany killed by SIGSEGV
[abrt] epiphany-runtime: g_type_check_instance(): epiphany killed by SIGSEGV
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Catanzaro
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:09f15aca7960831ac46c3d9d58b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-09 20:35 EDT by Diogo Campos
Modified: 2015-08-25 14:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 09:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (59.18 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: core_backtrace (8.19 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: dso_list (16.04 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: environ (1.72 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: maps (76.65 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: mountinfo (3.32 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: open_fds (2.59 KB, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: proc_pid_status (1010 bytes, text/plain)
2015-08-09 20:35 EDT, Diogo Campos
no flags Details
File: var_log_messages (307 bytes, text/plain)
2015-08-09 20:36 EDT, Diogo Campos
no flags Details

  None (edit)
Description Diogo Campos 2015-08-09 20:35:28 EDT
Description of problem:
I closed a tab.

Version-Release number of selected component:
epiphany-runtime-3.17.2-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        epiphany
crash_function: g_type_check_instance
executable:     /usr/bin/epiphany
global_pid:     2427
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_type_check_instance at gtype.c:4134
 #1 g_signal_handler_disconnect at gsignal.c:2584
 #2 WebKit::WebContextMenuProxyGtk::~WebContextMenuProxyGtk at /usr/src/debug/webkitgtk-2.9.5/Source/WebKit2/UIProcess/gtk/WebContextMenuProxyGtk.cpp:175
 #4 WTF::RefCounted<WebKit::WebContextMenuProxy>::deref at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/RefCounted.h:146
 #5 WTF::derefIfNotNull<WebKit::WebContextMenuProxy> at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/PassRefPtr.h:42
 #6 WTF::RefPtr<WebKit::WebContextMenuProxy>::~RefPtr at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/RefPtr.h:59
 #7 WebKit::WebPageProxy::~WebPageProxy at /usr/src/debug/webkitgtk-2.9.5/Source/WebKit2/UIProcess/WebPageProxy.cpp:497
 #9 WTF::ThreadSafeRefCounted<API::Object>::deref at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/ThreadSafeRefCounted.h:112
 #10 WTF::derefIfNotNull<WebKit::WebPageProxy> at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/PassRefPtr.h:42
 #11 WTF::RefPtr<WebKit::WebPageProxy>::~RefPtr at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/RefPtr.h:59
Comment 1 Diogo Campos 2015-08-09 20:35:35 EDT
Created attachment 1060841 [details]
File: backtrace
Comment 2 Diogo Campos 2015-08-09 20:35:37 EDT
Created attachment 1060842 [details]
File: cgroup
Comment 3 Diogo Campos 2015-08-09 20:35:39 EDT
Created attachment 1060843 [details]
File: core_backtrace
Comment 4 Diogo Campos 2015-08-09 20:35:42 EDT
Created attachment 1060844 [details]
File: dso_list
Comment 5 Diogo Campos 2015-08-09 20:35:44 EDT
Created attachment 1060845 [details]
File: environ
Comment 6 Diogo Campos 2015-08-09 20:35:46 EDT
Created attachment 1060846 [details]
File: limits
Comment 7 Diogo Campos 2015-08-09 20:35:51 EDT
Created attachment 1060847 [details]
File: maps
Comment 8 Diogo Campos 2015-08-09 20:35:54 EDT
Created attachment 1060848 [details]
File: mountinfo
Comment 9 Diogo Campos 2015-08-09 20:35:55 EDT
Created attachment 1060849 [details]
File: namespaces
Comment 10 Diogo Campos 2015-08-09 20:35:57 EDT
Created attachment 1060850 [details]
File: open_fds
Comment 11 Diogo Campos 2015-08-09 20:35:58 EDT
Created attachment 1060851 [details]
File: proc_pid_status
Comment 12 Diogo Campos 2015-08-09 20:36:01 EDT
Created attachment 1060852 [details]
File: var_log_messages
Comment 13 Diogo Campos 2015-08-11 18:01:18 EDT
Another user experienced a similar problem:

I closed the Web Inspector.

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        epiphany https://hacks.mozilla.org/2015/08/trainspotting-firefox-40/
crash_function: g_type_check_instance
executable:     /usr/bin/epiphany
global_pid:     12531
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
package:        epiphany-runtime-3.17.2-1.fc23
reason:         epiphany killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 14 Diogo Campos 2015-08-21 23:13:50 EDT
WebKitGtk4 2.9.90 from here[1] seemed to fix this (frequent) crash. BUT made a bunch of webpages become painful slow (Diaspora, Facebook, etc) - so I reverted it for now.

[1]: http://koji.fedoraproject.org/koji/buildinfo?buildID=678357
Comment 15 Michael Catanzaro 2015-08-22 11:07:02 EDT
To be clear: you mean 2.9.5 does not have this performance problem?
Comment 16 Diogo Campos 2015-08-22 13:53:55 EDT
Correct.
Comment 17 Michael Catanzaro 2015-08-24 09:29:40 EDT
I will close this bug since you report that the original problem seems to be fixed. Indeed, FAF shows crashes only with 2.9.5.

(In reply to Diogo Campos from comment #14)
> BUT made
> a bunch of webpages become painful slow (Diaspora, Facebook, etc) - so I
> reverted it for now.

Thanks for the heads-up. This is probably fixed by https://trac.webkit.org/changeset/188858
Comment 18 Diogo Campos 2015-08-24 14:44:18 EDT
Good. Thank you :)
Comment 19 Diogo Campos 2015-08-25 14:09:41 EDT
Slowness is fixed with 2.9.90-2 (sorry for not opening a new bug).
Thank you, again.

Note You need to log in before you can comment on or make changes to this bug.