Bug 1251879 - Lost the subcomponent selectlist box in batch move bugs page
Lost the subcomponent selectlist box in batch move bugs page
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Jeff Fearn
Rony Gong
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 04:22 EDT by Rony Gong
Modified: 2015-09-20 19:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-20 19:29:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2015-08-10 04:22:11 EDT
Description of problem:
Lost the subcomponent selectlist box in batch move bugs page

Version-Release number of selected component (if applicable):
4.4.9038-3

How reproducible:
Always

Steps to Reproduce:
1.Do an advanced search with below conditions:
classification: Red Hat
Product:  RHEL7
Component: lvm2
Subcomponent: Dislplaying and Reporting
2.Then batch move the search list.
3.In the batch move page, try to change subcompnent

Actual results:
The subcomponent selectlist box can't viewable.

Expected results:
User could view subcomponent selectlist box and change it.

Additional info:
Comment 1 Rony Gong 2015-08-16 23:05:42 EDT
Tested on 
QA environment(bzweb01-qe) with version(4.4.9039-1, DB: mysql)
QA environment(bzperfweb01.app.qa) with version(4.4.9039-1, DB: psql )
Result: Fail
Steps:
1.Do an advanced search with below conditions:
classification: Red Hat
Product:  RHEL7
Component: lvm2
Subcomponent: Dislplaying and Reporting
2.Then batch move the search list.
3.In the batch move page, try to change subcompnent
==>There only show item '--do not change--' in the subcomponent select list, it doesnt' work same as current production that could chose other subcomponent.
Comment 2 Jeff Fearn 2015-08-16 23:10:43 EDT
(In reply to Rony Gong from comment #1)
> Tested on 
> QA environment(bzweb01-qe) with version(4.4.9039-1, DB: mysql)
> QA environment(bzperfweb01.app.qa) with version(4.4.9039-1, DB: psql )
> Result: Fail
> Steps:
> 1.Do an advanced search with below conditions:
> classification: Red Hat
> Product:  RHEL7
> Component: lvm2
> Subcomponent: Dislplaying and Reporting
> 2.Then batch move the search list.
> 3.In the batch move page, try to change subcompnent
> ==>There only show item '--do not change--' in the subcomponent select list,
> it doesnt' work same as current production that could chose other
> subcomponent.

Currently in production you can choose components and subcomponents that are not constrained by the product or component. This is broken and I believe the current way of forcing the user to chose a product to get a component list, and a component to get the subcomponent list, is the sane way of doing this.

Needinfo PO.
Comment 3 Jason McDonald 2015-08-17 01:10:11 EDT
(In reply to Jeff Fearn from comment #2)
> Currently in production you can choose components and subcomponents that are
> not constrained by the product or component. This is broken and I believe
> the current way of forcing the user to chose a product to get a component
> list, and a component to get the subcomponent list, is the sane way of doing
> this.

Agreed.  The form should not allow the user to make invalid selections.
Comment 4 Rony Gong 2015-08-18 02:47:21 EDT
After research more, QE find it could change component and subcomponent when the list bugs are in same products, but below mirrors should be fixed

1. Go to bug list which contains bugs that all belongs to product 'Bugzilla', like
https://bzperfweb01.app.qa.eng.nay.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&classification=Community&component=Internal%20Tools&list_id=3187219&order=priority%2Cbug_severity&product=Bugzilla&query_format=advanced&rh_sub_components=Rules%20Engine&tweak=1

2.Then try to batch change this bug list, try to select component, it only contains --do_not_change--

3.The only way to full fill the component select list is selecting a product in product select list. But seems I don't want to change these bugs product to other, just like the default option 'do not change'. 

Actual Results:
I need select 'Bugzilla' in the product select list box, then I could select component

Expected Results:
No need select 'Bugzilla' in the product select list box, the component select list is full fill with product Bugzilla's components.
Comment 5 Jeff Fearn 2015-08-19 19:22:27 EDT
(In reply to Rony Gong from comment #4)
> After research more, QE find it could change component and subcomponent when
> the list bugs are in same products, but below mirrors should be fixed
> 
> 1. Go to bug list which contains bugs that all belongs to product
> 'Bugzilla', like
> https://bzperfweb01.app.qa.eng.nay.redhat.com/buglist.
> cgi?bug_status=NEW&bug_status=ASSIGNED&classification=Community&component=Int
> ernal%20Tools&list_id=3187219&order=priority%2Cbug_severity&product=Bugzilla&
> query_format=advanced&rh_sub_components=Rules%20Engine&tweak=1
> 
> 2.Then try to batch change this bug list, try to select component, it only
> contains --do_not_change--
> 
> 3.The only way to full fill the component select list is selecting a product
> in product select list. But seems I don't want to change these bugs product
> to other, just like the default option 'do not change'. 
> 
> Actual Results:
> I need select 'Bugzilla' in the product select list box, then I could select
> component
> 
> Expected Results:
> No need select 'Bugzilla' in the product select list box, the component
> select list is full fill with product Bugzilla's components.

You can not have the product set to  '--do_not_change--' and the component loaded with the new widgets. The only way to do this would be to set the product to the correct value so the component widget can function properly.

IMO it's a bad change because it will force loading the 18K Fedora components for Fedora bugs.
Comment 6 Rony Gong 2015-08-19 19:59:28 EDT
> IMO it's a bad change because it will force loading the 18K Fedora
> components for Fedora bugs.

QE also agree with this point, then QE suggest add a comment or hint besides the component field, the connect maybe looks like: please select a product first
Comment 7 Jeff Fearn 2015-08-20 20:04:34 EDT
(In reply to Rony Gong from comment #6)
> > IMO it's a bad change because it will force loading the 18K Fedora
> > components for Fedora bugs.
> 
> QE also agree with this point, then QE suggest add a comment or hint besides
> the component field, the connect maybe looks like: please select a product
> first

Hi, we don't want to block sprint 39 for this issue. Please open a new bug for this issue. IMO the interaction here needs some thought to make the 3 selectors work in a user friendly manner.
Comment 8 Rony Gong 2015-08-20 21:56:45 EDT
(In reply to Jeff Fearn from comment #7)
> (In reply to Rony Gong from comment #6)
> > > IMO it's a bad change because it will force loading the 18K Fedora
> > > components for Fedora bugs.
> > 
> > QE also agree with this point, then QE suggest add a comment or hint besides
> > the component field, the connect maybe looks like: please select a product
> > first
> 
> Hi, we don't want to block sprint 39 for this issue. Please open a new bug
> for this issue. IMO the interaction here needs some thought to make the 3
> selectors work in a user friendly manner.

QE filed a new bug 1251879 to track this,  and verify current bug as PASS.
Comment 9 Matt Tyson 2015-09-20 19:29:24 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.