This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 125189 - kernel BUG at mm/shmem.c:614!
kernel BUG at mm/shmem.c:614!
Status: CLOSED DUPLICATE of bug 125143
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 10:55 EDT by Brian Millett
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2004-06-03 10:55:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040220

Description of problem:
I have a toshiba laptop 1135-S155.  The kernel 2.6.6-1.406 works just
fine.
With the newest kernel 2.6.6-1.411, I get the following kernel BUG

Jun  3 09:39:07 mktg6nt kernel: ------------[ cut here ]------------
Jun  3 09:39:07 mktg6nt kernel: kernel BUG at mm/shmem.c:614!
Jun  3 09:39:07 mktg6nt kernel: invalid operand: 0000 [#1]
Jun  3 09:39:07 mktg6nt kernel: Modules linked in: pcspkr usb_storage
loop binfmt_misc parport_pc lp parport nfsd exportfs lockd autofs4
rfcomm l2cap ds yenta_socket pcmcia_core orinoco_pci orinoco hermes
iptable_nat iptable_mangle ipt_limit ipt_REJECT ipt_state ip_conntrack
iptable_filter ip_tables sg scsi_mod microcode sunrpc dm_mod joydev
hci_usb bluetooth ohci_hcd ehci_hcd uhci_hcd button battery asus_acpi
ac ext3 jbd
Jun  3 09:39:07 mktg6nt kernel: CPU:    0
Jun  3 09:39:07 mktg6nt kernel: EIP:    0060:[<021399da>]    Not tainted
Jun  3 09:39:07 mktg6nt kernel: EFLAGS: 00013206   (2.6.6-1.411)
Jun  3 09:39:07 mktg6nt kernel: EIP is at shmem_delete_inode+0x7f/0x95
Jun  3 09:39:07 mktg6nt kernel: eax: 20bf2574   ebx: 20bf24dc   ecx:
20bf24dcedx: 00000000
Jun  3 09:39:07 mktg6nt kernel: esi: 20bf24dc   edi: 20bf2480   ebp:
20c133c8esp: 0b1bddd8
Jun  3 09:39:07 mktg6nt kernel: ds: 007b   es: 007b   ss: 0068
Jun  3 09:39:07 mktg6nt kernel: Process X (pid: 3652,
threadinfo=0b1bd000 task=1fbc9930)
Jun  3 09:39:07 mktg6nt kernel: Stack: 20bf24dc 0213995b 20bf24dc
124d9804 0215315a 20bf24dc 20bf24dc 021532db
Jun  3 09:39:07 mktg6nt gdm[3649]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Jun  3 09:39:07 mktg6nt udev[3739]: removing device node '/udev/vcsa7'
Jun  3 09:39:07 mktg6nt udev[3737]: removing device node '/udev/vcs7'
Jun  3 09:39:07 mktg6nt kernel:        124d9804 0215135b 1edce480
20e7e300 02140f3f 1fd90968 00000000 023715d0
Jun  3 09:39:08 mktg6nt kernel:        00000000 0217b093 1fd90968
0217ba52 00000100 00000000 00009be5 00000000
Jun  3 09:39:08 mktg6nt kernel: Call Trace:
Jun  3 09:39:08 mktg6nt kernel:  [<0213995b>] shmem_delete_inode+0x0/0x95
Jun  3 09:39:08 mktg6nt kernel:  [<0215315a>]
generic_delete_inode+0x98/0xe1
Jun  3 09:39:08 mktg6nt kernel:  [<021532db>] iput+0x58/0x5a
Jun  3 09:39:08 mktg6nt kernel:  [<0215135b>] dput+0x122/0x13a
Jun  3 09:39:08 mktg6nt kernel:  [<02140f3f>] __fput+0xb3/0xd1
Jun  3 09:39:08 mktg6nt kernel:  [<0217b093>] shm_destroy+0x43/0x5e
Jun  3 09:39:08 mktg6nt kernel:  [<0217ba52>] sys_shmctl+0x589/0x735
Jun  3 09:39:08 mktg6nt kernel:  [<0212a8fd>]
__generic_file_aio_read+0x157/0x171
Jun  3 09:39:08 mktg6nt kernel:  [<021340e1>] zap_pte_range+0x1e0/0x238
Jun  3 09:39:09 mktg6nt kernel:  [<02134172>] zap_pmd_range+0x39/0x54
Jun  3 09:39:09 mktg6nt kernel:  [<021341c9>] unmap_page_range+0x3c/0x57
Jun  3 09:39:09 mktg6nt kernel:  [<021342d5>] unmap_vmas+0xf1/0x1ae
Jun  3 09:39:09 mktg6nt kernel:  [<0217b133>] shm_close+0x85/0x96
Jun  3 09:39:09 mktg6nt kernel:  [<02137096>] unmap_vma+0x4a/0x60
Jun  3 09:39:09 mktg6nt kernel:  [<021370ba>] unmap_vma_list+0xe/0x17
Jun  3 09:39:09 mktg6nt kernel:  [<02137395>] do_munmap+0xfd/0x107
Jun  3 09:39:09 mktg6nt kernel:  [<0210aaee>] sys_ipc+0x191/0x1a7
Jun  3 09:39:09 mktg6nt kernel:  [<02137395>] do_munmap+0xfd/0x107
Jun  3 09:39:09 mktg6nt kernel:
Jun  3 09:39:09 mktg6nt kernel: Code: 0f 0b 66 02 f9 3b 29 02 ff 45 0c
89 f0 5b 5e 5f 5d e9 70 8d


Version-Release number of selected component (if applicable):
2.6.6-1.411

How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
    

Actual Results:  see kernel BUG in discription

Expected Results:  Should have booted

Additional info:
Comment 1 Brian Millett 2004-06-03 11:06:46 EDT

*** This bug has been marked as a duplicate of 125143 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.