Bug 1252059 - The "OK" button should be pressed twice in order to make a template in the "New Template" window
The "OK" button should be pressed twice in order to make a template in the "N...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: jniederm
Karolína Hajná
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 11:04 EDT by Idan Shaby
Modified: 2016-05-19 21:24 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:23:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
rule-engine: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47955 ovirt-engine-3.6 MERGED webadmin: Icons validation reworked Never

  None (edit)
Description Idan Shaby 2015-08-10 11:04:25 EDT
Description of problem:
When making a template from a non active snapshot in a turned off vm, one should press on the "OK" button twice in order to start the operation.

Version-Release number of selected component (if applicable):
e8c46f8ef3b3cb6e31a2ddbbe8640ab30deee310

How reproducible:
100%

Steps to Reproduce:
1. Create a vm and turn it on.
2. Take a snapshot of the vm.
3. Click on the new snapshot and then on "Make Template" under the "Snapshots" sub tab.
4. Name the template and click on the OK button.

Actual results:
Nothing happens. The OK button should be clicked again.

Expected results:
Should work after the first click..

Additional info:
Comment 1 Tomas Jelinek 2015-08-20 08:56:38 EDT
Can not simulate on 3.6 nor on current master. I would suspect it has been fixed by https://gerrit.ovirt.org/#/c/45091/

Changing to modified so it will be verified.
Comment 2 Karolína Hajná 2015-10-22 06:35:52 EDT
This bug persist on 3.6.0.1-1.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-22 06:35:57 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Tomas Jelinek 2015-10-23 04:06:48 EDT
hmm, I still can not simulate this. Looking into code the suspicious part is that after the OK is pressed the progress is not shown. On my setup it is not really visible but maybe this is the problem.
@Karolina: Could you please try to press OK only once and wait for couple of seconds if it will work?
Comment 5 Karolína Hajná 2015-10-27 04:23:18 EDT
I waited a minute and the window didn't close. I had to click on OK second time. It happens on both ovirt and rhevm so it's not related only to one of them. 

I used ovirt-engine-3.6.0.1-1.el6.noarch and rhevm-3.6.0.1-0.1.el6.noarch packages to test it.
Comment 6 Tomas Jelinek 2015-10-29 08:23:38 EDT
it is related to icon validation - is is already fixed on master (https://gerrit.ovirt.org/#/c/46707/), just needs to be backported.
Comment 7 Yaniv Lavi (Dary) 2015-10-29 08:28:34 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 8 Karolína Hajná 2015-11-26 11:14:37 EST
Verified on rhevm-3.6.1-0.2.el6.noarch (build 3.6.0-22)
Comment 9 Sandro Bonazzola 2015-12-16 07:23:56 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.