Bug 1252092 - three finger tap stops working in kernel-4.2.0-0.rc6.git0.1.fc24.x86_64
three finger tap stops working in kernel-4.2.0-0.rc6.git0.1.fc24.x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 13:00 EDT by Kevin Fenzi
Modified: 2016-04-18 03:59 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 03:59:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evemu-record of trackpad when trying to do a 3 finger tap (6.60 KB, text/plain)
2015-08-20 13:20 EDT, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2015-08-10 13:00:28 EDT
With kernel-4.2.0-0.rc5.git3.1.fc24.x86_64 I am able to do three finger taps (to paste) just fine. With kernel-4.2.0-0.rc6.git0.1.fc24.x86_64 they don't work and instead pull up a menu (just like a two finger tap does). 

Happy to test or gather more info...
Comment 1 Peter Hutterer 2015-08-10 17:44:30 EDT
can you give me an evemu recording of the non-working three-finger tap on the rc6 kernel please? thanks
Comment 2 Kevin Fenzi 2015-08-17 14:45:24 EDT
And of course I can't duplicate this now after a cold boot back to rc6 or rc7. 

:( 

I wonder if there's some issue with warm boots... ie, it gets in a non normal state after just a warm reboot. Will keep trying to duplicate, but feel free to close this for now and I can re-open if I can get a valid reproducer.
Comment 3 Benjamin Tissoires 2015-08-18 09:17:53 EDT
Closing as per the reporter's request
Comment 4 Kevin Fenzi 2015-08-20 13:19:40 EDT
ok. I still haven't managed to get a 100% reproducer, but I did get into that state. 

It seems to happen after something crashes causing the desktop to be very unresponsive while it's gathering a core. 

I did get a evemu recording this time however, so perhaps that will help...
Comment 5 Kevin Fenzi 2015-08-20 13:20:38 EDT
Created attachment 1065334 [details]
evemu-record of trackpad when trying to do a 3 finger tap
Comment 6 Benjamin Tissoires 2015-08-25 10:27:29 EDT
(In reply to Kevin Fenzi from comment #4)
> ok. I still haven't managed to get a 100% reproducer, but I did get into
> that state. 
> 
> It seems to happen after something crashes causing the desktop to be very
> unresponsive while it's gathering a core. 
> 
> I did get a evemu recording this time however, so perhaps that will help...

It does help. But the worrying thing is that the evemu recording corresponds to a double tap, not a triple tap. I am not saying that you messed up, but either the kernel messed up or the firmware did.

And my problem here is that the double tap vs triple tap is given by the firmware and translated as such by the kernel.

Ideally, could you record while you see the problem both the evemu ouptu (like you did) but also the ps2emu[1] output?
Chandler made a copr to install it more conveniently[2]. Just run "sudo ps2emu-record" and save the output.

[1] https://github.com/Lyude/ps2emu
[2] https://copr.fedoraproject.org/coprs/lyude/ps2emu-tools/
Comment 7 Kevin Fenzi 2015-08-25 17:51:07 EDT
sure. I have that installed now and the next time it happens I will gather both.
Comment 8 Benjamin Tissoires 2015-09-29 04:40:43 EDT
I think this must also have to do with http://www.spinics.net/lists/linux-input/msg41176.html. I asked Josh to revert the patch in bug #1262434, so once this ine is out, could you tell us if this fixed your issue?
Comment 9 Kevin Fenzi 2015-09-29 12:40:33 EDT
Well, I have not seen it since the last report here... ;( 

I've been waiting for it to happen so I could gather the info you wanted, but so far it's not...
Comment 10 Benjamin Tissoires 2016-04-18 03:59:51 EDT
Given the last comment and that it has been nearly 5 months, closing as current release.

Please re-open if the problem still persists

Note You need to log in before you can comment on or make changes to this bug.