This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1252199 - "active-count" metric is missing for "blocking-bounded-queue-thread-pool"
"active-count" metric is missing for "blocking-bounded-queue-thread-pool"
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: jboss-set
Martin Simka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 20:41 EDT by Anu Saji
Modified: 2015-08-11 20:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 20:37:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anu Saji 2015-08-10 20:41:26 EDT
Description of problem:
The "active-count" metric is missing for blocking-bounded-queue-thread-pool 

Version-Release number of selected component (if applicable):
EAP6.3


How reproducible:
In standalone mode 

standalone.xml configure something similar to this 
~~~
<subsystem xmlns="urn:jboss:domain:threads:1.1">
            <thread-factory name="http-connector-factory" group-name="bq-thread-pool" thread-name-pattern="HTTPS-%t"/>
            <blocking-bounded-queue-thread-pool name="bq-thread-pool">
                <core-threads count="400"/>
                <queue-length count="200"/>
                <max-threads count="600"/>
                <keepalive-time time="1" unit="minutes"/>
                <thread-factory name="http-connector-factory"/>
            </blocking-bounded-queue-thread-pool>
        </subsystem>
~~~


Output
~~~

ls -l /subsystem=threads/blocking-bounded-queue-thread-pool=bq-thread-pool
ATTRIBUTE            VALUE                              TYPE    
allow-core-timeout   false                              BOOLEAN 
core-threads         400                                INT     
current-thread-count 0                                  INT     
keepalive-time       {"time" => 1L,"unit" => "MINUTES"} OBJECT  
largest-thread-count 0                                  INT     
max-threads          600                                INT     
name                 bq-thread-pool                     STRING  
queue-length         200                                INT     
queue-size           0                                  INT     
rejected-count       0                                  INT     
thread-factory       http-connector-factory             STRING  
~~~



Actual results:
ls -l /subsystem=threads/blocking-bounded-queue-thread-pool=bq-thread-pool
ATTRIBUTE            VALUE                              TYPE    
allow-core-timeout   false                              BOOLEAN 
core-threads         400                                INT     
current-thread-count 0                                  INT     
keepalive-time       {"time" => 1L,"unit" => "MINUTES"} OBJECT  
largest-thread-count 0                                  INT     
max-threads          600                                INT     
name                 bq-thread-pool                     STRING  
queue-length         200                                INT     
queue-size           0                                  INT     
rejected-count       0                                  INT     
thread-factory       http-connector-factory             STRING  
~~~

Expected results:

In addition to the earlier metrics expect the following count
~~~
ATTRIBUTE            VALUE     TYPE
active-count         0         INT
~~~
Additional info:
Comment 3 Brian Stansberry 2015-08-11 20:37:11 EDT
This a duplicate of the 1021911 Enhancement request.

Note You need to log in before you can comment on or make changes to this bug.