Bug 1252339 - engine setup should use by default the firewall if only one available
engine setup should use by default the firewall if only one available
Status: CLOSED DUPLICATE of bug 1250196
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 04:22 EDT by Omer Frenkel
Modified: 2015-10-27 19:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 07:06:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omer Frenkel 2015-08-11 04:22:41 EDT
this is a suggestion for small improvement:
if engine setup identifies only one firewall manager, it should suggest it as default. for example, while installing 3.6 beta, i got:

 Setup can automatically configure the firewall on this system.
          Note: automatic configuration of the firewall may overwrite current settings.
          Do you want Setup to configure the firewall? (Yes, No) [Yes]: yes
          The following firewall managers were detected on this system: iptables
          Firewall manager to configure (iptables): 
[ ERROR ] Invalid value
          Firewall manager to configure (iptables): 

^ since only one option, it would be nice if it was suggested as default,
ans user wouldn't need to type the manager name (see below)

[ ERROR ] Invalid value
          Firewall manager to configure (iptables): iptables


Version-Release number of selected component (if applicable):
3.6

How reproducible:
always


Actual results:
          Firewall manager to configure (iptables): 

Expected results:
          Firewall manager to configure (iptables) [iptables]: 
                                                       ^^^
then user can just hit enter and continue, instead of typing the manager, which anyway is the only option.
Comment 1 Yaniv Lavi 2015-08-20 07:06:47 EDT

*** This bug has been marked as a duplicate of bug 1250196 ***

Note You need to log in before you can comment on or make changes to this bug.