This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 125238 - ls --format=single-column doesn't format correctly
ls --format=single-column doesn't format correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 127234 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 19:31 EDT by Vince Skahan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.2.1-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 05:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vince Skahan 2004-06-03 19:31:20 EDT
Description of problem:

ls --format=single-column does not work

Version-Release number of selected component (if applicable):

FC2 latest

How reproducible:

always

Steps to Reproduce:
1. cd /bin
2. do a "ls -1" (it works, you get a single-column output)
3. do a "ls --format=single-column (fails, you get multi-column 
output)
  
Actual results:

the --format option to 'ls' appears to not function

Expected results:

it should work as documented in the man page (rh9's version worked ok)

Additional info:

workaround is to use "ls -1" to get single column output until the 
bug is fixed.  I didn't check the other "--format" possibilities to 
see if they're all broken in FC2.
Comment 1 Tim Waugh 2004-06-04 05:21:47 EDT
Thanks for the report.  Fixed in 5.2.1-14.
Comment 2 Tim Waugh 2004-07-05 05:15:06 EDT
*** Bug 127234 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.