Bug 1252383 - [abrt] gnome-shell: meta_clutter_init(): gnome-shell killed by SIGTRAP
[abrt] gnome-shell: meta_clutter_init(): gnome-shell killed by SIGTRAP
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
x86_64 Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
abrt_hash:2f6e8f46f8daf996a8eb872a3ed...
:
: 1267237 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 05:42 EDT by Michal Domonkos
Modified: 2015-09-29 08:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 14:05:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.87 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: cgroup (181 bytes, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: core_backtrace (3.63 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: dso_list (12.97 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: environ (1.28 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: machineid (135 bytes, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: maps (62.98 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: open_fds (311 bytes, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: proc_pid_status (1.05 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details
File: var_log_messages (10.52 KB, text/plain)
2015-08-11 05:43 EDT, Michal Domonkos
no flags Details

  None (edit)
Description Michal Domonkos 2015-08-11 05:42:58 EDT
Description of problem:
1. Install the xorg.conf file attached to bug 1168502
2. Restart the gdm service

Version-Release number of selected component:
gnome-shell-3.14.4-24.el7

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: meta_clutter_init
executable:     /usr/bin/gnome-shell
kernel:         3.10.0-302.el7.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #2 meta_clutter_init at backends/meta-backend.c:459
 #3 meta_init at core/main.c:358
Comment 1 Michal Domonkos 2015-08-11 05:43:00 EDT
Created attachment 1061409 [details]
File: backtrace
Comment 2 Michal Domonkos 2015-08-11 05:43:01 EDT
Created attachment 1061410 [details]
File: cgroup
Comment 3 Michal Domonkos 2015-08-11 05:43:02 EDT
Created attachment 1061411 [details]
File: core_backtrace
Comment 4 Michal Domonkos 2015-08-11 05:43:03 EDT
Created attachment 1061412 [details]
File: dso_list
Comment 5 Michal Domonkos 2015-08-11 05:43:05 EDT
Created attachment 1061413 [details]
File: environ
Comment 6 Michal Domonkos 2015-08-11 05:43:06 EDT
Created attachment 1061414 [details]
File: limits
Comment 7 Michal Domonkos 2015-08-11 05:43:07 EDT
Created attachment 1061415 [details]
File: machineid
Comment 8 Michal Domonkos 2015-08-11 05:43:08 EDT
Created attachment 1061416 [details]
File: maps
Comment 9 Michal Domonkos 2015-08-11 05:43:11 EDT
Created attachment 1061417 [details]
File: open_fds
Comment 10 Michal Domonkos 2015-08-11 05:43:12 EDT
Created attachment 1061418 [details]
File: proc_pid_status
Comment 11 Michal Domonkos 2015-08-11 05:43:13 EDT
Created attachment 1061419 [details]
File: var_log_messages
Comment 13 Florian Müllner 2015-09-24 14:04:46 EDT
From the log:

Aug 11 11:28:22 testbox gnome-session[5442]: (gnome-shell:14367): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to open display ':0'
Aug 11 11:28:22 testbox gnome-session[5442]: (gnome-shell:14367): mutter-ERROR **: Unable to initialize Clutter.

We fail to establish a connection with the display server. I'm afraid there isn't any more graceful way to deal with this than treating it as a fatal error as we do now.
Comment 14 RHEL Product and Program Management 2015-09-24 14:05:49 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 15 Vadim Rutkovsky 2015-09-29 08:28:26 EDT
*** Bug 1267237 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.