Bug 1252483 - Demo network provisioning: public and private are shared, private has no tenant
Demo network provisioning: public and private are shared, private has no tenant
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Liberty
Unspecified Unspecified
medium Severity medium
: ---
: Liberty
Assigned To: Martin Magr
Luigi Toscano
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 10:16 EDT by Luigi Toscano
Modified: 2016-03-14 11:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 11:52:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 237781 None None None Never
OpenStack gerrit 249778 None None None Never
OpenStack gerrit 249779 None None None Never

  None (edit)
Description Luigi Toscano 2015-08-11 10:16:28 EDT
Description of problem:
When CONFIG_PROVISION_DEMO=y, the settings of the network is different than in the past (and probably not properly working):
- both the public and the private network have marked shared=True
- private network is not assigned to any tenant (I suppose this is the reason why the shared property can't be removed).

This could be related to a change in packstack or to a change in the default values of python-neutronclient (thanks Martin Magr).


Version-Release number of selected component (if applicable):
openstack-packstack-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch
openstack-packstack-puppet-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch
openstack-puppet-modules-2015.1.8-8.el7ost.noarch


How reproducible:
Set CONFIG_PROVISION_DEMO=y (or keep it, as it is the default). The only other changes I applied to the default packstack answer file are:
CONFIG_MANILA_INSTALL=y
CONFIG_HEAT_INSTALL=y
CONFIG_SAHARA_INSTALL=y
CONFIG_TROVE_INSTALL=y
Comment 3 Luigi Toscano 2016-03-14 11:52:34 EDT
Both issues from the description are now fixed:
- shared is False for both public and the demo-specific private;
- private is assigned to the demo project

Verified on an up-to-date CentOS 7, with:

RDO Liberty:
openstack-packstack-7.0.0-0.10.dev1682.g42b3426.el7.noarch
openstack-packstack-puppet-7.0.0-0.10.dev1682.g42b3426.el7.noarch
openstack-puppet-modules-7.0.1-1.el7.noarch

RDO Mitaka (DLRN snapshot):
openstack-packstack-8.0.0-0.20160303124552.0476b9b.el7.centos.noarch
openstack-packstack-puppet-8.0.0-0.20160303124552.0476b9b.el7.centos.noarch
openstack-puppet-modules-8.0.0a0-0.20160304203011.7dc7e93.el7.centos.noarch

Note You need to log in before you can comment on or make changes to this bug.