Bug 1252494 - VDSM doesn't start and does not report the reason in the log
VDSM doesn't start and does not report the reason in the log
Status: CLOSED NOTABUG
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
---
x86_64 Linux
unspecified Severity unspecified (vote)
: ovirt-3.6.0-rc
: ---
Assigned To: Yaniv Bronhaim
Gil Klein
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 10:31 EDT by Maor
Modified: 2016-02-10 14:13 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 12:20:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Maor 2015-08-11 10:31:52 EDT
Description of problem:

I've been trying to install VDSM on RHEL-7.2 Using the following rpms:

vdsm-yajsonrpc-4.17.0-1239.git6575e3f.el7.noarch
vdsm-infra-4.17.0-1239.git6575e3f.el7.noarch
vdsm-python-4.17.0-1239.git6575e3f.el7.noarch
vdsm-4.17.0-1239.git6575e3f.el7.noarch
vdsm-xmlrpc-4.17.0-1239.git6575e3f.el7.noarch
vdsm-cli-4.17.0-1239.git6575e3f.el7.noarch
vdsm-jsonrpc-4.17.0-1239.git6575e3f.el7.noarch

libvirt-daemon-driver-nwfilter-1.2.17-3.el7.x86_64
libvirt-daemon-config-nwfilter-1.2.17-3.el7.x86_64
libvirt-daemon-driver-nodedev-1.2.17-3.el7.x86_64
libvirt-client-1.2.17-3.el7.x86_64
libvirt-daemon-driver-qemu-1.2.17-3.el7.x86_64
libvirt-lock-sanlock-1.2.17-3.el7.x86_64
libvirt-daemon-kvm-1.2.17-3.el7.x86_64
libvirt-daemon-1.2.17-3.el7.x86_64
libvirt-python-1.2.17-2.el7.x86_64
libvirt-daemon-driver-storage-1.2.17-3.el7.x86_64
libvirt-daemon-driver-interface-1.2.17-3.el7.x86_64
libvirt-daemon-driver-network-1.2.17-3.el7.x86_64
libvirt-daemon-driver-secret-1.2.17-3.el7.x86_64

The host version is:
 Red Hat Enterprise Linux Server release 7.2 Beta (Maipo)


When I try to start my VDSM service, the service reported as failed and I could not see any reason for that in the log.

It appears that /etc/vdsm/logger.conf was not exists, so I tried to manually add it from another host.
Once I've added it, it tried to use /dev/log for the handler_syslog, but this was not configured in my Host as well

only after I've remove all the references of handler_syslog from the logger.conf , I've eventually managed to start the VDSM service

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Rhel 7.2 beta
2. Install VDSM
3.

Actual results:
VDSM does not run

Expected results:
VDSM should run

Additional info:
Comment 2 Nir Soffer 2015-08-12 08:40:39 EDT
The root cause looks like bad upgrade to rhel 7.2, with missing /dev/log.

Also the repositories shown in the description seems to be mixed up. You
should use the repsitories "rhel-7.2" and "rhel-7.2-optional" and remove the
one named "latest-RHEL".

On my clean rhel 7.2 installation, /dev/log exists, so vdsm should start
correctly if logger.conf was installed.

Patch https://gerrit.ovirt.org/44728 will make it easier to debug such issues.

We should check 2 things:
1. Upgrading from rhel 7.1 to 7.2 - if broken, open platform bug
2. Why logger.conf was missing - maybe related to missing /dev/log?
Comment 3 Yaniv Bronhaim 2015-10-13 12:20:43 EDT
I don't see it in my rhel7.2 environment - If this issue raises again please reopen

Note You need to log in before you can comment on or make changes to this bug.