Bug 1252625 - texlive file conflicts
texlive file conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 18:47 EDT by Bruno Wolff III
Modified: 2015-09-11 14:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 14:43:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-08-11 18:47:21 EDT
Error: Transaction check error:
  file /usr/lib/libkpathsea.so.6 from install of texlive-lib-4:2015-2.20150728_r37987.fc24.i686 conflicts with file from package texlive-kpathsea-lib-4:2014-12.20140525_r34255.fc24.1.i686
  file /usr/lib/libptexenc.so.1 from install of texlive-lib-4:2015-2.20150728_r37987.fc24.i686 conflicts with file from package texlive-kpathsea-lib-4:2014-12.20140525_r34255.fc24.1.i686
  file /usr/bin/mag from install of texlive-ps2pk-bin-4:svn36790.0-2.20150728_r37987.fc24.i686 conflicts with file from package texlive-ps2pkm-bin-4:svn30088.0-12.20140525_r34255.fc24.1.i686
  file /usr/bin/pfb2pfa from install of texlive-ps2pk-bin-4:svn36790.0-2.20150728_r37987.fc24.i686 conflicts with file from package texlive-ps2pkm-bin-4:svn30088.0-12.20140525_r34255.fc24.1.i686
  file /usr/bin/pk2bm from install of texlive-ps2pk-bin-4:svn36790.0-2.20150728_r37987.fc24.i686 conflicts with file from package texlive-ps2pkm-bin-4:svn30088.0-12.20140525_r34255.fc24.1.i686
  file /usr/bin/ps2pk from install of texlive-ps2pk-bin-4:svn36790.0-2.20150728_r37987.fc24.i686 conflicts with file from package texlive-ps2pkm-bin-4:svn30088.0-12.20140525_r34255.fc24.1.i686
  file /usr/share/man/man1/ps2pk.1.gz from install of texlive-ps2pk-4:svn37078.0-2.fc24.noarch conflicts with file from package texlive-ps2pkm-4:svn29764.1.6_beta_1-12.fc24.1.noarch
Comment 1 Bruno Wolff III 2015-08-11 18:50:56 EDT
It might be the case that something is pinning the older texlive packages.
Comment 2 Bruno Wolff III 2015-08-11 20:34:44 EDT
It looks like texlive-kpathsea-lib,  texlive-ps2pkm-bin and texlive-ps2pkm may need to be obsoleted.
Comment 3 Bruno Wolff III 2015-08-11 20:58:40 EDT
texlive-mh also seems to have been removed.

I was able to use dnf distro-sync --allowerasing to get texlive updates. However there were also a lot of downgrades done in the process.
Install     80 Packages
Upgrade    397 Packages
Remove      16 Packages
Downgrade  867 Packages

Most of the removals were not texlive packages, but all of the downgrades were.
Comment 4 Mattias Ellert 2015-08-18 04:30:28 EDT
There are some obsoletes there, but they are not sufficient. E.g.

# rpm -q --qf='%{epoch}:%{version}\n' texlive-mh
4:svn29420.0
# dnf repoquery --obsoletes texlive-lib.x86_64 | grep 'texlive-mh\s'
texlive-mh <= 3:2015

3:2015 < 4:svn29420.0

# rpm -q --qf='%{epoch}:%{version}\n' texlive-kpathsea-lib
4:2014
# dnf repoquery --obsoletes texlive-lib.x86_64 | grep texlive-kpathsea-lib
texlive-kpathsea-lib <= 2014

2014 < 4:2014

These are only the ones I have installed - there might be others.
Comment 5 Andre Robatino 2015-09-11 11:13:38 EDT
Today's 20150911 Rawhide texlive update fixes the file conflict for me (although I had already removed texlive-mh manually, so I don't know if it was a complete fix).
Comment 6 Tom "spot" Callaway 2015-09-11 14:43:23 EDT
This is now fixed in rawhide. Please reopen if you find conflicts.

Note You need to log in before you can comment on or make changes to this bug.