Bug 1252655 - Enable EGL null platform
Enable EGL null platform
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 22:03 EDT by Dawid Gajownik
Modified: 2015-08-12 13:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 13:53:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Gajownik 2015-08-11 22:03:27 EDT
Hi,

please enable EGL null platform in mesa 10.x. It's useful for offscreen rendering.
http://cgit.freedesktop.org/mesa/mesa/commit/?id=5eca41665bbd6deb5ffff011e47ff0cec41916da

--with-egl-platforms=x11,drm,null%{?with_wayland:,wayland} \

Thanks,
   Dawid
Comment 1 Dawid Gajownik 2015-08-12 13:53:18 EDT
Hmmm... it looks that null platform is broken since mesa 10.4. I suspect that it was caused by these patches http://lists.freedesktop.org/archives/mesa-dev/2014-November/070204.html

In that case enabling null platform does not make sense anymore.

Note You need to log in before you can comment on or make changes to this bug.