Bug 1252692 - [QE] Add options unauthenticatedIdentity and password-stacking to AbstractServerLoginModule options table
[QE] Add options unauthenticatedIdentity and password-stacking to AbstractSer...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.4.0
Unspecified Unspecified
unspecified Severity medium
: post-GA
: ---
Assigned To: Zach Rhoads
Ondrej Lukas
https://access.stage.redhat.com/docum...
: Documentation, Triaged
Depends On:
Blocks: 1233012
  Show dependency treegraph
 
Reported: 2015-08-12 01:58 EDT by Ondrej Lukas
Modified: 2015-10-20 08:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 08:46:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Lukas 2015-08-12 01:58:29 EDT
Book: Login Module Reference
Revision: n_1575841_login-module-reference_version_6.4_edition_1.0_release_0-revision_6701191
Section: ABSTRACT LOGIN MODULES

Issue description:
Chapter AbstractServerLoginModule contains table with AbstractServerLoginModule options. This table is missing options unauthenticatedIdentity and password-stacking since these options are described below in their own sections. However it can be confused for customer because another Login Module options tables include all options of particular Login Module in one table. Options unauthenticatedIdentity and password-stacking should be added to AbstractServerLoginModule options table. Description of this option would be something like "see section 2.1.1. UnauthenticatedIdentity for details" (or "see section 2.1.2. Password Stacking for details"). 

Option unauthenticatedIdentity has type "string" and none default value (use word "none" instead of empty space).
Option password-stacking has type "useFirstPass or false" with default value "false".

Then table with unauthenticatedIdentity option should be removed from section 2.1.1. UnauthenticatedIdentity since it will be included in AbstractServerLoginModule option table.

Suggestions for improvement:
Use mentioned above notes for improving AbstractServerLoginModule chapter.
Comment 3 Ondrej Lukas 2015-08-21 04:50:06 EDT
Verified in revision "n_1601531_login-module-reference_version_6.4_edition_1.0_release_0-revision_6805721" of https://access.stage.redhat.com/documentation/en/red-hat-jboss-enterprise-application-platform/version-6.4/login-module-reference

Note You need to log in before you can comment on or make changes to this bug.