Bug 1252750 - Can't detach local export domain
Can't detach local export domain
Status: CLOSED DUPLICATE of bug 1245249
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity high
: m1
: 3.6.0
Assigned To: Vered Volansky
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 04:13 EDT by Aharon Canan
Modified: 2016-03-10 01:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 04:17:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aharon Canan 2015-08-12 04:13:54 EDT
Description of problem:
I can't detach local export domain which is in maintenance state.

Version-Release number of selected component (if applicable):
3.6.0-5


How reproducible:
100%

Steps to Reproduce:
1. Create local export domain
2. Maintain it
3.

Actual results:
fails CDA

from GUI:
Error while executing action: Cannot remove Storage.
The Storage Domain metadata indicates it is already attached to a Data Center hence cannot be formatted.
To remove the Storage Domain one should either remove it without the format option or attach it to an existing Data Center, detach it, and try again.

From engine.log:
2015-08-12 11:07:03,943 INFO  [org.ovirt.engine.core.bll.storage.RemoveStorageDomainCommand] (default task-9) [24095177] Lock Acquired to object 'EngineLock:{exclusiveLocks='[7500b744-3142-442e-80e5-3ad5663c7bc3=<STORAGE, ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'
2015-08-12 11:07:03,957 INFO  [org.ovirt.engine.core.bll.storage.ConnectStorageToVdsCommand] (default task-9) [3b28a01e] Running command: ConnectStorageToVdsCommand internal: true. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group CREATE_STORAGE_DOMAIN with role type ADMIN
2015-08-12 11:07:03,962 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (default task-9) [3b28a01e] START, ConnectStorageServerVDSCommand(HostName = camel-vdsb, StorageServerConnectionManagementVDSParameters:{runAsync='true', hostId='ed46d4b8-73c8-42e4-8a4f-bde7f811d59f', storagePoolId='00000000-0000-0000-0000-000000000000', storageType='LOCALFS', connectionList='[StorageServerConnections:{id='d8cecc14-e16e-44da-8674-e17f8e214c36', connection='/tmp/export', iqn='null', vfsType='null', mountOptions='null', nfsVersion='null', nfsRetrans='null', nfsTimeo='null', iface='null', netIfaceName='null'}]'}), log id: 4030fd88
2015-08-12 11:07:03,992 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (default task-9) [3b28a01e] FINISH, ConnectStorageServerVDSCommand, return: {d8cecc14-e16e-44da-8674-e17f8e214c36=0}, log id: 4030fd88
2015-08-12 11:07:03,998 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetStorageDomainInfoVDSCommand] (default task-9) [3b28a01e] START, HSMGetStorageDomainInfoVDSCommand(HostName = camel-vdsb, HSMGetStorageDomainInfoVDSCommandParameters:{runAsync='true', hostId='ed46d4b8-73c8-42e4-8a4f-bde7f811d59f', storageDomainId='7500b744-3142-442e-80e5-3ad5663c7bc3'}), log id: 39877c85
2015-08-12 11:07:04,957 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetStorageDomainInfoVDSCommand] (default task-9) [3b28a01e] FINISH, HSMGetStorageDomainInfoVDSCommand, return: <StorageDomainStatic:{name='export3', id='7500b744-3142-442e-80e5-3ad5663c7bc3'}, ef5760f9-c704-4fcc-b245-1d3cee37ffb9>, log id: 39877c85
2015-08-12 11:07:04,964 INFO  [org.ovirt.engine.core.bll.storage.DisconnectStorageServerConnectionCommand] (default task-9) [6efd86b0] Running command: DisconnectStorageServerConnectionCommand internal: true. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group CREATE_STORAGE_DOMAIN with role type ADMIN
2015-08-12 11:07:04,967 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (default task-9) [6efd86b0] START, DisconnectStorageServerVDSCommand(HostName = camel-vdsb, StorageServerConnectionManagementVDSParameters:{runAsync='true', hostId='ed46d4b8-73c8-42e4-8a4f-bde7f811d59f', storagePoolId='00000000-0000-0000-0000-000000000000', storageType='LOCALFS', connectionList='[StorageServerConnections:{id='d8cecc14-e16e-44da-8674-e17f8e214c36', connection='/tmp/export', iqn='null', vfsType='null', mountOptions='null', nfsVersion='null', nfsRetrans='null', nfsTimeo='null', iface='null', netIfaceName='null'}]'}), log id: 411aa2a9
2015-08-12 11:07:05,832 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (default task-9) [6efd86b0] FINISH, DisconnectStorageServerVDSCommand, return: {d8cecc14-e16e-44da-8674-e17f8e214c36=0}, log id: 411aa2a9
2015-08-12 11:07:05,834 WARN  [org.ovirt.engine.core.bll.storage.RemoveStorageDomainCommand] (default task-9) [] CanDoAction of action 'RemoveStorageDomain' failed for user admin@internal. Reasons: VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_FORMAT_STORAGE_DOMAIN_WITH_ATTACHED_DATA_DOMAIN
2015-08-12 11:07:05,834 INFO  [org.ovirt.engine.core.bll.storage.RemoveStorageDomainCommand] (default task-9) [] Lock freed to object 'EngineLock:{exclusiveLocks='[7500b744-3142-442e-80e5-3ad5663c7bc3=<STORAGE, ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'

Expected results:
We should be able to detach local export domain in order to remove.

Additional info:
Comment 1 Vered Volansky 2015-08-12 04:17:12 EDT

*** This bug has been marked as a duplicate of bug 1245249 ***

Note You need to log in before you can comment on or make changes to this bug.