Bug 1252841 - Clicking OK in New VM/Pool dialog without filled required field shows advanced options
Clicking OK in New VM/Pool dialog without filled required field shows advance...
Status: CLOSED NEXTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.2.0
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
: UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 06:52 EDT by Karolína Hajná
Modified: 2017-07-14 09:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 09:08:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tjelinek: ovirt‑4.2?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)
New Pool dialog bug (46.33 KB, image/png)
2015-08-12 06:52 EDT, Karolína Hajná
no flags Details
screen-cast: New VM Pool dialog (1.01 MB, application/ogg)
2015-08-13 04:32 EDT, Einav Cohen
no flags Details

  None (edit)
Description Karolína Hajná 2015-08-12 06:52:30 EDT
Created attachment 1061905 [details]
New Pool dialog bug

Description of problem:
When creating new VM or Pool, clicking OK without filled required fields while in Console tab (with hidden advanced options) shows advanced options. Button for showing/hiding all options still shows "Show advanced options".

Version-Release number of selected component (if applicable):
3.6.0-0.0.master.20150804111407.git122a3a0.el6

How reproducible:
100%

Steps to Reproduce:
1. Open New VM/Pool dialog
2. Go to Console tab (with hidden advanced options)
3. Click OK

Actual results:
Advanced options are shown and button for showing/hiding these options has "Show advanced options" label.

Expected results:
Advanced options stay hidden.
Comment 1 Einav Cohen 2015-08-13 04:32:02 EDT
Created attachment 1062404 [details]
screen-cast: New VM Pool dialog
Comment 2 Einav Cohen 2015-08-13 04:54:38 EDT
I reproduced on latest 'master'. 

Note that when if the currently-selected side-section contains validation errors, the problem will not reproduce (see attachment 1062404 [details]); 
This problem may be happening only when the selected side-section changes automatically to 'jump' to a side-section that contains errors [i.e. related to the fix of bug 1057386 / https://gerrit.ovirt.org/#/c/27781/]. 

Please consult awels if you need assistance.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 07:00:11 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Tomas Jelinek 2017-07-14 09:08:50 EDT
tried on current master and is already fixed

Note You need to log in before you can comment on or make changes to this bug.