Bug 1252843 - error :'Modules libvirt are not configured' when restarting vdsm service (rhel 6.7)
error :'Modules libvirt are not configured' when restarting vdsm service (rhe...
Status: CLOSED DUPLICATE of bug 1243810
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Yeela Kaplan
Shira Maximov
infra
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 07:08 EDT by Shira Maximov
Modified: 2016-02-10 14:18 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 06:19:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages and vdsm logs attached (734.94 KB, application/x-gzip)
2015-08-12 07:08 EDT, Shira Maximov
no flags Details

  None (edit)
Description Shira Maximov 2015-08-12 07:08:05 EDT
Created attachment 1061907 [details]
/var/log/messages and vdsm logs attached

Description of problem:
restart vdsmd service :

[root@lynx18 ~]# service vdsmd restart
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm: Running run_final_hooks                              [  OK  ]
vdsm stop                                                  [  OK  ]
libvirtd start/running, process 117458
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running configure_vdsm_logs
vdsm: Running wait_for_network
vdsm: Running run_init_hooks
vdsm: Running upgraded_version_check
vdsm: Running check_is_configured
libvirt is already configured for vdsm
vdsm: Running validate_configuration
SUCCESS: ssl configured to true. No conflicts
vdsm: Running prepare_transient_repository
vdsm: Running syslog_available
vdsm: Running nwfilter
vdsm: Running dummybr
vdsm: Running load_needed_modules
vdsm: Running tune_system
vdsm: Running test_space
vdsm: Running test_lo
Upgrading to unified persistence if needed
Upgrading to v3.x networking if needed
Starting up vdsm daemon: 
vdsm start                                                 [  OK  ]
[root@lynx18 ~]# service vdsmd restart
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm: Running run_final_hooks                              [  OK  ]
vdsm stop                                                  [  OK  ]
libvirtd start/running, process 119778
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running configure_vdsm_logs
vdsm: Running wait_for_network
vdsm: Running run_init_hooks
vdsm: Running upgraded_version_check
vdsm: Running check_is_configured
libvirt is already configured for vdsm
vdsm: Running validate_configuration
SUCCESS: ssl configured to true. No conflicts
vdsm: Running prepare_transient_repository
vdsm: Running syslog_available
vdsm: Running nwfilter
vdsm: Running dummybr
vdsm: Running load_needed_modules
vdsm: Running tune_system
vdsm: Running test_space
vdsm: Running test_lo
Upgrading to unified persistence if needed
Upgrading to v3.x networking if needed
Starting up vdsm daemon: 
vdsm start                                                 [  OK  ]
[root@lynx18 ~]# service vdsmd restart
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm: Running run_final_hooks                              [  OK  ]
vdsm stop                                                  [  OK  ]
libvirtd start/running, process 10421
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running configure_vdsm_logs
vdsm: Running wait_for_network
vdsm: Running run_init_hooks
vdsm: Running upgraded_version_check
vdsm: Running check_is_configured
libvirt is not configured for vdsm yet
Modules libvirt are not configured
Error:  

One of the modules is not configured to work with VDSM.
To configure the module use the following:
'vdsm-tool configure [--module module-name]'.

If all modules are not configured try to use:
'vdsm-tool configure --force'
(The force flag will stop the module's service and start it
afterwards automatically to load the new configuration.)
 

 vdsm: stopped during execute check_is_configured task (task returned with error code 1).
vdsm start                                                 [FAILED]



in order to start vdsm i need to to the following steps :
1. 
[root@lynx18 ~]# service vdsmd stop
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm: not running                                          [FAILED]
vdsm: Running run_final_hooks
vdsm stop                                                  [  OK  ]

2.
[root@lynx18 ~]# service supervdsmd stop
Shutting down supervdsm daemon: 
supervdsm watchdog stop                                    [  OK  ]
supervdsm stop                                             [  OK  ]

3.
[root@lynx18 ~]# vdsm-tool configure --module libvirt

Checking configuration status...

libvirt is not configured for vdsm yet
SUCCESS: ssl configured to true. No conflicts

Running configure...
Reconfiguration of libvirt is done.

Done configuring modules to VDSM. 

Done configuring modules to VDSM.

4.
[root@lynx18 ~]# service supervdsmd start
supervdsm start                                            [  OK  ]

5.
[root@lynx18 ~]# service vdsmd start
libvirtd start/running, process 12226
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running configure_vdsm_logs
vdsm: Running wait_for_network
vdsm: Running run_init_hooks
vdsm: Running upgraded_version_check
vdsm: Running check_is_configured
libvirt is already configured for vdsm
vdsm: Running validate_configuration
SUCCESS: ssl configured to true. No conflicts
vdsm: Running prepare_transient_repository
vdsm: Running syslog_available
vdsm: Running nwfilter
vdsm: Running dummybr
vdsm: Running load_needed_modules
vdsm: Running tune_system
vdsm: Running test_space
vdsm: Running test_lo
Upgrading to unified persistence if needed
Upgrading to v3.x networking if needed
Starting up vdsm daemon: 
vdsm start           


             
Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 6.7 (Santiago):
vdsm-4.16.24-2.el6ev.x86_64


How reproducible:
50%

Steps to Reproduce:
1.restart vdsm service 
2.
3.

Actual results:
start vdsm failes

Expected results:
start vdsm should success 

Additional info:
Comment 1 Yeela Kaplan 2015-08-17 11:37:15 EDT
When configuring libvirt vdsm-tool disables sysv management of libvirt and uses only upstart to manage libvirtd.

a puppet-agent that is installed on this specific el6 host turns sysv management of libvirt on:

/var/log/messages:
Aug 17 17:06:30 lynx18 puppet-agent[115404]: (/Stage[main]/Libvirt::Service/Service[libvirtd]/enable) enable changed 'false' to 'true'

When trying to restart vdsmd, vdsm checks libvirt configuration and realizes sysv management of libvirt is on, and returns False.
Causing vdsm restart to fail until you run 'vdsm-tool configure --module libvirt' that will disable libvirtd management by sysv again allowing vdsm to start.

I think this is not a vdsm bug, as there are not supposed to be any other services on the hypervisor playing with libvirt.
Dan,
what do you think?
Comment 2 Dan Kenigsberg 2015-08-19 06:19:33 EDT
(In reply to Yeela Kaplan from comment #1)
> 
> I think this is not a vdsm bug, as there are not supposed to be any other
> services on the hypervisor playing with libvirt.
> Dan,
> what do you think?

You are right right.

Shira, please make sure that puppet does not enable libvirt again.

*** This bug has been marked as a duplicate of bug 1243810 ***

Note You need to log in before you can comment on or make changes to this bug.