Bug 1252888 - Background fails render on ppc64
Background fails render on ppc64
Status: CLOSED DUPLICATE of bug 1250168
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.2
ppc64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 08:54 EDT by Vitezslav Humpa
Modified: 2015-09-15 13:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 13:18:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppc64 background (153.68 KB, image/png)
2015-08-12 08:54 EDT, Vitezslav Humpa
no flags Details
ppc64 lockscreen (24.32 KB, image/png)
2015-08-12 08:55 EDT, Vitezslav Humpa
no flags Details
ppc64le background for comparison (551.29 KB, image/png)
2015-08-12 08:56 EDT, Vitezslav Humpa
no flags Details

  None (edit)
Description Vitezslav Humpa 2015-08-12 08:54:47 EDT
Created attachment 1061938 [details]
ppc64 background

Description of problem:
Background does not render within GNOME on ppc64. We get a grey background with default configuration as well as when using the custom one. Control center renders the miniatures OK, though also does no show panel previews (see screenshots for comparison). All seem to be set properly in org.gnome.desktop.background and the background images exist.

Same for the lock screen background.

With ppc64le all is okay. This might be related to big-endian issue: #1250168
Running desktop via VNC using Xorg with Xvnc plugin. 

Found nothing of interest in session logs.

Version-Release number of selected component (if applicable):
mutter-3.14.4-10.el7.ppc64
gnome-desktop3-3.14.2-2.el7.ppc64
gnome-shell-3.14.4-24.el7.ppc64
Comment 1 Vitezslav Humpa 2015-08-12 08:55:23 EDT
Created attachment 1061939 [details]
ppc64 lockscreen
Comment 2 Vitezslav Humpa 2015-08-12 08:56:14 EDT
Created attachment 1061940 [details]
ppc64le background for comparison
Comment 3 Oded Gabbay 2015-09-11 17:03:31 EDT
I checked this report on latest nightly rhel 7.2 build - RHEL-7.2-20150910.2 Server ppc64 - and it doesn't reproduce there.

The background issue indeed comes from #1250168, which was solved in 
mesa-10.6.5-1.20150824.el7.ppc64, which is included in that nightly build I wrote above, but not included in RHEL 7.2 beta

I suggest to install that build (or a newer build) and re-test.
Comment 4 Tomas Pelka 2015-09-15 08:40:06 EDT
I was not able to reproduce too. I think it would be safe to close as next release.
Comment 5 Ray Strode [halfline] 2015-09-15 13:18:02 EDT
okay let's dupe to 1250168

*** This bug has been marked as a duplicate of bug 1250168 ***

Note You need to log in before you can comment on or make changes to this bug.