This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 125290 - coreutils is missing dependencies
coreutils is missing dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 11:08 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.2.1-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 12:36:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-06-04 11:08:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The coreutils package is missing a couple of dependencies:

@@ -9,6 +9,7 @@
 Group:   System Environment/Base
 Url:     ftp://alpha.gnu.org/gnu/coreutils/
 %if %{WITH_SELINUX}
+Requires: libselinux
 BuildRequires: libselinux-devel
 %endif

AND

-BuildRequires: gettext libtermcap-devel
+BuildRequires: gettext libtermcap-devel bison


If bison is not installed, this package will not build. Also, some
utilities link against the libselinux shared libraries. This package
must state its required at runtime.

Version-Release number of selected component (if applicable):
coreutils-5.2.1-13

How reproducible:
Always

Steps to Reproduce:
1. uninstall bison...rpm -e --nodeps bison
2. rpmbuild -bb /usr/src/redhat/SPEC/coreutils.spec

Additional info:
Comment 1 Tim Waugh 2004-06-04 11:54:00 EDT
Why do you think this line is needed?:

Requires: libselinux

The automatic dependency ought to be sufficient:

$ rpm -q --requires coreutils|grep libselinux
libselinux.so.1

I've added the bison build requirement -- thanks.
Comment 2 Robert Scheck 2004-07-16 14:03:18 EDT
This bug can be closed, fixed since coreutils-5.2.1-15 in Fedora 
Development.

Note You need to log in before you can comment on or make changes to this bug.