Bug 1252917 - Virt-viewer password cannot be set.
Virt-viewer password cannot be set.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 09:50 EDT by Bill Sanford
Modified: 2015-08-13 04:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 14:00:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2015-08-12 09:50:23 EDT
Description of problem:
Virt-viewer password cannot be set with "-spice port=3000,password=redhat" or at the (qemu) prompt with "set_password spice redhat."

Version-Release number of selected component (if applicable):
RHEL-6.7-20150805.2 - base and optional - Host and client
Supp-6.7-RHEL-6-20150702.0 - Host and client

RHEL-6-20150702.0 - guest 
Firefox 38.0.1 - guest 

On the Host:
spice-glib-0.26-4.el6.x86_64
spice-gtk-devel-0.26-4.el6.x86_64
spice-gtk-python-0.26-4.el6.x86_64
spice-server-devel-0.12.4-12.el6.x86_64
spice-gtk-0.26-4.el6.x86_64
spice-protocol-0.12.6-1.el6.noarch
spice-glib-devel-0.26-4.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-server-0.12.4-12.el6.x86_64
spice-xpi-2.7-27.el6.x86_64
spice-vdagent-0.14.0-9.el6.x86_64
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
spice-gtk-tools-0.26-4.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. With either "-spice port=3000,password=redhat" or at the (qemu) prompt with "set_password spice redhat" try to set password
2.
3.

Actual results:
Error message with "Could not set password."

Expected results:
Password is set.

Additional info:
Comment 2 Christophe Fergeau 2015-08-12 10:11:55 EDT
What qemu version are you testing with? qemu-kvm-0.12.1.2-2.479.el6.x86_64 + spice-server-0.12.4-12.el6.x86_64 works as expected here.
Comment 3 Bill Sanford 2015-08-12 11:22:25 EDT
[root@unused-10-19-63-157 ~]# rpm -qa | grep qemu
qemu-kvm-0.12.1.2-2.479.el6.x86_64
qemu-img-0.12.1.2-2.479.el6.x86_64
gpxe-roms-qemu-0.9.7-6.14.el6.noarch
[root@unused-10-19-63-157 ~]# rpm -qa | grep spice-server
spice-server-devel-0.12.4-12.el6.x86_64
spice-server-0.12.4-12.el6.x86_64
[root@unused-10-19-63-157 ~]#
Comment 4 Christophe Fergeau 2015-08-12 11:33:00 EDT
What I'm testing is:
- start qemu with '/usr/libexec/qemu-kvm -spice port=3000,password=redhat -monitor stdio'
- connect to the host with ssh -X
- start 'remote-viewer spice://localhost:3000' and connect to the guest with 'redhat'
- exit remote-viewer
- type 'set_password spice foo' at the (qemu) prompt
-  start 'remote-viewer spice://localhost:3000' and connect to the guest with 'foo'

In both cases, I can successfully connect to the guest after typing the correct password.
Are you following the exact same steps, or are you doing something else?
Comment 5 David Blechter 2015-08-12 11:51:56 EDT
(In reply to Bill Sanford from comment #0)
> Description of problem:
> Virt-viewer password cannot be set with "-spice port=3000,password=redhat"
> or at the (qemu) prompt with "set_password spice redhat."
> 
> Version-Release number of selected component (if applicable):
> RHEL-6.7-20150805.2 - base and optional - Host and client
> Supp-6.7-RHEL-6-20150702.0 - Host and client
> 
> RHEL-6-20150702.0 - guest 
> Firefox 38.0.1 - guest 
> 
> On the Host:
> spice-glib-0.26-4.el6.x86_64
> spice-gtk-devel-0.26-4.el6.x86_64
> spice-gtk-python-0.26-4.el6.x86_64
> spice-server-devel-0.12.4-12.el6.x86_64
> spice-gtk-0.26-4.el6.x86_64
> spice-protocol-0.12.6-1.el6.noarch
> spice-glib-devel-0.26-4.el6.x86_64
> spice-usb-share-4.9-9.el6.x86_64
> spice-client-0.8.2-15.el6.x86_64
> spice-server-0.12.4-12.el6.x86_64
> spice-xpi-2.7-27.el6.x86_64
> spice-vdagent-0.14.0-9.el6.x86_64
> kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
> spice-gtk-tools-0.26-4.el6.x86_64
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. With either "-spice port=3000,password=redhat" or at the (qemu) prompt
> with "set_password spice redhat" try to set password
> 2.
> 3.
> 
> Actual results:
> Error message with "Could not set password."
> 
> Expected results:
> Password is set.
> 
> Additional info:

was it tested during the rhel 6.7 cycle? Did it pass and fails now? What does regression means
Comment 7 Tomas Pelka 2015-08-12 12:56:14 EDT
Need info unset by accident.
Comment 8 Bill Sanford 2015-08-12 14:00:04 EDT
I was trying a much bigger config with the password added in.

Christophe's comment #4, works.
Comment 9 Christophe Fergeau 2015-08-13 04:00:18 EDT
(In reply to Bill Sanford from comment #8)
> I was trying a much bigger config with the password added in.

If you managed to get into a situation where setting the password was failing, I'd be very interested in knowing how to reproduce even if the steps to reproduce are bigger/longer. https://bugzilla.redhat.com/show_bug.cgi?id=1234197 seems to be caused by set_password failing, but so far I've only reproduced it in a full RHEV instance, not by running qemu by hand.

Note You need to log in before you can comment on or make changes to this bug.