Bug 1252989 - View Current Requests/Sessions doesn't work
View Current Requests/Sessions doesn't work
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: JON (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Van Halbert
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 12:16 EDT by Filip Nguyen
Modified: 2015-08-25 05:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 05:23:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
admin-console (223.87 KB, image/png)
2015-08-12 12:18 EDT, Filip Nguyen
no flags Details
jon-view-requests (243.79 KB, image/png)
2015-08-12 12:18 EDT, Filip Nguyen
no flags Details
jon-view-sessions (242.71 KB, image/png)
2015-08-12 12:19 EDT, Filip Nguyen
no flags Details

  None (edit)
Description Filip Nguyen 2015-08-12 12:16:37 EDT
The operations seem to return non-sense data. I have long running query and this query can be seen in web management console of AS (see attached screenshots). However, when I run View Current Requests/Sessions in JON I get some nonsense data in tables (again see screenshots).
Comment 1 Filip Nguyen 2015-08-12 12:18:06 EDT
Created attachment 1062094 [details]
admin-console
Comment 2 Filip Nguyen 2015-08-12 12:18:34 EDT
Created attachment 1062095 [details]
jon-view-requests
Comment 3 Filip Nguyen 2015-08-12 12:19:04 EDT
Created attachment 1062098 [details]
jon-view-sessions
Comment 4 Van Halbert 2015-08-21 15:39:53 EDT
Filip,

looking at the images for jon-view-requests and jon-view-sessions, it appears that those images are for different operations.  Its displaying what VDB's are deployed.  And based on the tree-view on the left, it appears that's what its suppose to be showing.
Comment 5 Ted Jones 2015-08-21 16:56:03 EDT
It appears the that operations were run at the VDB grouping level instead of for the ModeShape VDB. When run with the target VDB selected the correct response is returned. I see the same behavior with other groupings within RHQ, so I believe that is expected, although confusing, behavior (maybe a bug?). For example, the same result set is returned when executing operations under EAP->Subsystems->Security->Security Domains.
Comment 6 Filip Nguyen 2015-08-24 08:53:29 EDT
Thanks, yes that confused me. After 1248550 is fixed I will verify them in one batch and most possibly mark this 1252989 as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.