Bug 1252998 - RHEL6 deprecation warning on md5 module
RHEL6 deprecation warning on md5 module
Status: CLOSED ERRATA
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
: 1233425 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 13:02 EDT by Greg Nichols
Modified: 2015-11-19 11:35 EST (History)
2 users (show)

See Also:
Fixed In Version: redhat-certification-1.0-20150812
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 11:35:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2015-08-12 13:02:10 EDT
Description of problem:

When running rhcert-backend on RHEL6, the following warning appears:

/usr/lib/python2.6/site-packages/rhcert/crypto.py:16: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import os, md5, M2Crypto, magic


Version-Release number of selected component (if applicable):

redhat-certification 1.0 20150723
Comment 2 Greg Nichols 2015-08-12 15:21:24 EDT
*** Bug 1233425 has been marked as a duplicate of this bug. ***
Comment 4 Brian Brock 2015-09-10 12:28:32 EDT
verified, error message not seen during CLI runs:

redhat-certification-2.0-20150909.el6.noarch
redhat-certification-hardware-1.6.6-20150901.el6.noarch
Comment 6 errata-xmlrpc 2015-11-19 11:35:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2479.html

Note You need to log in before you can comment on or make changes to this bug.