Bug 1253020 - EFI Install is drastically different
EFI Install is drastically different
Status: CLOSED NOTABUG
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHCI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 1.0
Assigned To: james labocki
Sean Myers
Dan Macpherson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 14:11 EDT by Sean Myers
Modified: 2016-04-29 12:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 16:13:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
efi-boot install screen (76.09 KB, image/jpeg)
2015-08-12 14:11 EDT, Sean Myers
no flags Details

  None (edit)
Description Sean Myers 2015-08-12 14:11:18 EDT
Created attachment 1062165 [details]
efi-boot install screen

Description of problems:
When booting the ISO via EFI, the installation experience is very different and not automated.

Specifically:
- all install customizations are available, like configuring networking, storage, etc
- Network devices are named eno****, instead of eth0/1, as though net.ifnames is still set to 1
- storage needs to be manually configured, because the installer reports "Kickstart Insufficient" for that option.

Looking at /isolinux/grub.conf, and comparing it to /EFI/BOOT/grub.cfg, the kernel cmdlines are different.
Version-Release number of selected component (if applicable):
20150812.t. (latest at time of posting)

How reproducible:
Every time (when booting EFI)

Steps to Reproduce:
1. Boot the ISO in EFI mode

Actual results:
Different installation experience than booting under BIOS mode

Expected results:
The same installation experience as booting under BIOS mode

Additional info:
I see some special handling of the EFI boot partition in the kickstart config, so I'm assuming we do want EFI-boot installs to be the same as BIOS-boot installs.

I've filed this as one general EFI bug (rather than a bunch of separate ones) under the assumption that there's a common problem on the EFI side that, when fixed, could get everything working correctly. If this is incorrect, let me know and I'll open up separate bugs for each of the issues I've found.
Comment 1 Sean Myers 2015-08-12 16:13:47 EDT
I caught some EFI-awesomeness mid-flight, and this is no longer happening as of (at least) 20150812.t.5

Note You need to log in before you can comment on or make changes to this bug.