Bug 1253143 - error: Installed (but unpackaged) file(s) found:
error: Installed (but unpackaged) file(s) found:
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kross-interpreters (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ngo Than
Desktop QE
:
: 1048521 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 02:17 EDT by Tomas Pelka
Modified: 2015-09-01 07:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: kross-interpreters-4.10.5-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 09:48:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2015-08-13 02:17:20 EDT
Description of problem:
Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-mysql56-config$
Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-mysql56-config$
Installed (but unpackaged) file(s) found:
/usr/lib64/kde4/kross/kross.jar
/usr/lib64/kde4/krossjava.so

Version-Release number of selected component (if applicable):
kross-interpreters-4.10.5-5.el7

How reproducible:
100%

Steps to Reproduce:
1. build rpm from source
2.
3.

Actual results:
rpmbuild fail on mentioned error message

Expected results:
there should be no unpackaged files

Additional info:
I know it is minor issue, but we always guarantee (with a few exceptions) that src rpm can be build also by customer on standard env and not only in brew which is kind of non-standard build env.
Comment 1 Jan Grulich 2015-08-13 03:22:12 EDT
Isn't this a problem in SCL or whatever was used for your build? I don't see anything wrong in kross-interpreters spec file.
Comment 3 Ngo Than 2015-08-19 07:23:41 EDT
the problem is that somehow java is installed in the build enviroment by default (without any buildrequiremnt in the specfile, it's strange for me) and it's detected in cmakefile and so the kross java plugin was enable and built in this case.

It's a bug in the sepcfile. We have to make sure in the specfile that java plugin should not be built independent of java when kross_java is not set
Comment 12 errata-xmlrpc 2015-08-27 09:48:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1690.html
Comment 13 Jan Grulich 2015-09-01 07:09:47 EDT
*** Bug 1048521 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.