Bug 1253155 - Windows 10 i386 qxl VM BSOD when shutting down (bugcheck 9F) Probably caused by : dxgkrnl.sys
Windows 10 i386 qxl VM BSOD when shutting down (bugcheck 9F) Probably caused ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Windows
medium Severity high
: rc
: ---
Assigned To: Dmitry Fleytman
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 02:55 EDT by Xiaoqing Wei
Modified: 2016-11-06 07:23 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-06 07:23:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virsh dumpxml win10-i386 (5.57 KB, text/plain)
2015-08-13 02:55 EDT, Xiaoqing Wei
no flags Details
minidump (378.71 KB, application/octet-stream)
2015-08-13 02:59 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2015-08-13 02:55:38 EDT
Created attachment 1062350 [details]
virsh dumpxml win10-i386

Description of problem:

Windows 10 i386 qxl VM BSOD when shutting down (bugcheck 9F) Probably caused by : dxgkrnl.sys


Version-Release number of selected component (if applicable):

kernel-3.10.0-304.el7.x86_64
qemu-kvm-rhev-2.3.0-16.el7.x86_64
seabios-bin-1.7.5-11.el7.noarch
seavgabios-bin-1.7.5-11.el7.noarch

guest drivers
qxlwddm-0.1-12
virtio-win-prewhql-0.1-109


How reproducible:

rarely, about 1/20

Steps to Reproduce:

1. boot a vm, with virtio-blk, virtio-net, qxl+spice

2015-08-12 09:49:57.347+0000: starting up libvirt version: 1.2.17, package: 3.el7 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2015-07-30-06:50:09, x86-034.build.eng.bos.redhat.com), qemu version: 2.3.0 (qemu-kvm-rhev-2.3.0-16.el7)
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name win10-i386 -S -machine pc-i440fx-rhel7.2.0,accel=kvm,usb=off,vmport=off -cpu Broadwell-noTSX,+invtsc,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff -m 4096 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid 716da2d0-e170-4a6a-88a2-842b14c630ba -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/win10-i386.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/home/kvm_autotest_root/images/win10-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x8,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive if=none,id=drive-ide0-0-0,readonly=on,format=raw,cache=none,aio=native -device ide-cd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:a3:d6:61,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channel/target/win10-i386.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -device usb-tablet,id=input0 -spice port=5900,addr=0.0.0.0,disable-ticketing,image-compression=auto_glz,jpeg-wan-compression=auto,zlib-glz-wan-compression=auto,playback-compression=on,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on




2. install drivers(blk,net,qxl), make sure installed correctly, and not alert mark "!" in device mgmt
3. reboot, reboot, reboot, till bsod happen (with mem dump cfg correctly)

Actual results:

bsod, bug check 9F
details would be in separated comment


Expected results:

guest os should work well, no bsod

Additional info:

virsh dumpxml  attached.
Comment 1 Xiaoqing Wei 2015-08-13 02:59:52 EDT
Created attachment 1062351 [details]
minidump

additional detail:

guest using drivers in Win8 folder, as there's no one called win10.



Microsoft (R) Windows Debugger Version 10.0.10240.9 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\Administrator\Desktop\Minidump\Minidump\081215-2453-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available


************* Symbol Path validation summary **************
Response                         Time (ms)     Location
Deferred                                       srv*c:\DownstreamStore*http://msdl.microsoft.com/download/symbols
Symbol search path is: srv*c:\DownstreamStore*http://msdl.microsoft.com/download/symbols
Executable search path is: 
No .natvis files found at C:\Program Files (x86)\Windows Kits\10\Debuggers\x86\Visualizers.
Windows 10 Kernel Version 10240 MP (2 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 10240.16412.x86fre.th1.150729-1800
Machine Name:
Kernel base = 0x8121b000 PsLoadedModuleList = 0x8145ca38
Debug session time: Wed Aug 12 19:03:27.665 2015 (UTC + 8:00)
System Uptime: 0 days 0:09:47.508
Loading Kernel Symbols
.

Press ctrl-c (cdb, kd, ntsd) or ctrl-break (windbg) to abort symbol loads that take too long.
Run !sym noisy before .reload to track down problems loading symbols.

..............................................................
................................................................
.....................
Loading User Symbols
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 9F, {3, 8552d6a0, 828b89f0, a750f008}

Implicit thread is now 8dcc2b80
Probably caused by : dxgkrnl.sys ( dxgkrnl!BLTQUEUE::IssueCommand+45 )

Followup:     MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time.
Arguments:
Arg1: 00000003, A device object has been blocking an Irp for too long a time
Arg2: 8552d6a0, Physical Device Object of the stack
Arg3: 828b89f0, nt!TRIAGE_9F_POWER on Win7 and higher, otherwise the Functional Device Object of the stack
Arg4: a750f008, The blocked IRP

Debugging Details:
------------------

Implicit thread is now 8dcc2b80

SYSTEM_VERSION:  RHEL 7.2.0 PC (i440FX + PIIX, 1996)

BIOS_DATE:  04/01/2014

BUGCHECK_P1: 3

BUGCHECK_P2: ffffffff8552d6a0

BUGCHECK_P3: ffffffff828b89f0

BUGCHECK_P4: ffffffffa750f008

DRVPOWERSTATE_SUBCODE:  3

FAULTING_THREAD:  8dcc2b80

CPU_COUNT: 2

CPU_MHZ: 82f

CPU_VENDOR:  GenuineIntel

CPU_FAMILY: 6

CPU_MODEL: 3d

CPU_STEPPING: 2

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

ANALYSIS_VERSION: 10.0.10240.9 x86fre

LAST_CONTROL_TRANSFER:  from 812dbdfa to 813542d9

STACK_TEXT:  
8ad0d64c 812dbdfa 00000000 00000000 8dcc2b80 nt!KiSwapContext+0x19
8ad0d6b8 812db809 8db23af0 8dcc2b80 00000000 nt!KiSwapThread+0x19a
8ad0d6fc 812dd279 00000000 00000608 81474120 nt!KiCommitThreadWait+0x159
8ad0d7b0 8cbd982f 8db23af0 00000000 00000000 nt!KeWaitForSingleObject+0x299
8ad0d7d0 8cbd99cf 00000000 00000000 855dc008 dxgkrnl!BLTQUEUE::IssueCommand+0x45
8ad0d7ec 8cbd97d5 00000000 812e21b0 855db008 dxgkrnl!BLTQUEUE::Flush+0x5f
8ad0d7fc 8cbb22e9 00000002 855db008 855db018 dxgkrnl!DXGDODPRESENT::Flush+0x19
8ad0d814 8cbb2481 00000002 00000001 00000000 dxgkrnl!DXGADAPTER::AcquireCoreResourceExclusive+0x9b
8ad0d830 8cba44c2 00000002 88bad860 00000000 dxgkrnl!DXGADAPTER::AcquireCoreSync+0x65
8ad0d844 8cba4457 855db008 00000002 8552d758 dxgkrnl!DxgkAcquireAdapterCoreSync+0x28
8ad0d864 8cbdf6fd 8552d758 00000004 a750f078 dxgkrnl!DpiAcquireCoreSyncAccessSafe+0xab
8ad0d888 8cb795f6 00000004 8552d6a0 00000000 dxgkrnl!DpiPdoSetDevicePower+0x37
8ad0d8a0 8cbdeff1 8552d6a0 a750f008 855bd468 dxgkrnl!DpiPdoDispatchPower+0x10a
8ad0d968 8132ba0d 8552d6a0 a750f008 a750f0b8 dxgkrnl!DpiDispatchPower+0x6f
8ad0d980 8132e52a 8ad0d9a4 865d91aa 8552d6a0 nt!IopPoHandleIrp+0x27
8ad0d988 865d91aa 8552d6a0 a750f008 855bd468 nt!IoCallDriver+0x10
8ad0d9a4 865dc6af 855bd468 a750f008 855bd468 Wdf01000!FxPkgFdo::_PowerPassDown+0x3c [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\fdopower.cpp @ 86]
8ad0d9c0 865dfef3 00000001 0000008c 855bd468 Wdf01000!FxPkgFdo::PowerReleasePendingDeviceIrp+0x35 [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\fdopower.cpp @ 492]
8ad0d9ec 865e2aff 8ad0dabc 865e0216 855bd468 Wdf01000!FxPkgPnp::PowerGotoDxIoStopped+0x153 [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\powerstatemachine.cpp @ 2910]
8ad0d9f4 865e0216 855bd468 855bd5ac 855bd598 Wdf01000!FxPkgPnp::PowerGotoDNotZeroIoStopped+0xd [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\powerstatemachine.cpp @ 2651]
8ad0dabc 865e0dd5 8ad0dad8 855bd468 8665c910 Wdf01000!FxPkgPnp::PowerProcessEventInner+0x1f6 [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\powerstatemachine.cpp @ 1500]
8ad0daf4 865dca70 00000000 8665c910 855bd468 Wdf01000!FxPkgPnp::PowerProcessEvent+0x145 [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\powerstatemachine.cpp @ 1281]
8ad0db08 865d4694 8ad0db38 855bd468 855bc594 Wdf01000!FxPkgFdo::DispatchDeviceSetPower+0x74 [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\fdopower.cpp @ 346]
8ad0db3c 865d3684 0250f002 855be450 a750f008 Wdf01000!FxPkgPnp::Dispatch+0x1f4 [d:\th\minkernel\wdf\framework\shared\irphandlers\pnp\fxpkgpnp.cpp @ 647]
8ad0dbc8 8132b706 855be450 a750f008 00000000 Wdf01000!FxDevice::DispatchWithLock+0xf4 [d:\th\minkernel\wdf\framework\shared\core\fxdevice.cpp @ 1402]
8ad0dc30 812a9d81 8b58d678 9d0116ce 00000000 nt!PopIrpWorker+0x2b4
8ad0dc70 81354af1 8132b452 8b58d678 00000000 nt!PspSystemThreadStartup+0x5b
8ad0dc7c 00000000 00000000 03dcf810 00000023 nt!KiThreadStartup+0x15


STACK_COMMAND:  .thread 0xffffffff8dcc2b80 ; kb

FOLLOWUP_IP: 
dxgkrnl!BLTQUEUE::IssueCommand+45
8cbd982f 8b86cc000000    mov     eax,dword ptr [esi+0CCh]

SYMBOL_STACK_INDEX:  4

SYMBOL_NAME:  dxgkrnl!BLTQUEUE::IssueCommand+45

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dxgkrnl

IMAGE_NAME:  dxgkrnl.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  55b9938a

IMAGE_VERSION:  10.0.10240.16412

BUCKET_ID_FUNC_OFFSET:  45

FAILURE_BUCKET_ID:  0x9F_3_POWER_DOWN_dxgkrnl!BLTQUEUE::IssueCommand

BUCKET_ID:  0x9F_3_POWER_DOWN_dxgkrnl!BLTQUEUE::IssueCommand

PRIMARY_PROBLEM_CLASS:  0x9F_3_POWER_DOWN_dxgkrnl!BLTQUEUE::IssueCommand

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:0x9f_3_power_down_dxgkrnl!bltqueue::issuecommand

FAILURE_ID_HASH:  {afbbaaf3-ceb7-70fe-7fbd-f010e674b1f7}

Followup:     MachineOwner
---------
Comment 3 Xiaoqing Wei 2015-09-20 23:00:10 EDT
happen again, this time, the VM just boot, and did nothing.
wait for few min, and bsod.

kernel-3.10.0-315.el7.x86_64
qemu-kvm-rhev-2.3.0-23.el7.x86_64



/usr/libexec/qemu-kvm -name win10-32 -S -machine pc-i440fx-rhel7.2.0,accel=kvm,usb=off -cpu Broadwell-noTSX -m 2048 -realtime mlock=off -smp 2,sockets=2,cores=1,threads=1 -uuid 3fe19c2e-eb05-4205-b7d8-5467496ccf2a -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-win10-32/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot menu=on,strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 -device ahci,id=sata0,bus=pci.0,addr=0x5 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/home/win1032.raw,if=none,id=drive-virtio-disk0,format=raw,cache=none,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x9,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/home/en_windows_10_enterprise_x86_dvd_6851156.iso,if=none,id=drive-ide0-0-0,readonly=on,format=raw -device ide-cd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/home/skl.iso,if=none,id=drive-ide0-0-1,readonly=on,format=raw,cache=none -device ide-cd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1,bootindex=3 -netdev tap,fds=23:24:25:26,id=hostnet0,vhost=on,vhostfds=27:28:29:30 -device virtio-net-pci,mq=on,vectors=10,netdev=hostnet0,id=net0,mac=52:54:00:94:05:02,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=0.0.0.0,disable-ticketing,image-compression=auto_glz,jpeg-wan-compression=auto,zlib-glz-wan-compression=auto,playback-compression=on,streaming-video=filter,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -chardev spicevmc,id=charredir2,name=usbredir -device usb-redir,chardev=charredir2,id=redir2 -chardev spicevmc,id=charredir3,name=usbredir -device usb-redir,chardev=charredir3,id=redir3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -set device.virtio-disk0.scsi=on -msg timestamp=on
Comment 6 Yan Vugenfirer 2016-10-19 12:09:37 EDT
Cannot reproduce with current QXL WDDM driver that supports Win10.
Comment 7 Dmitry Fleytman 2016-10-25 06:56:03 EDT
Please re-test with v0.4-1
Comment 8 juzhang 2016-10-26 02:29:16 EDT
Hi Zhiyi,

Could you have a try and update the test result?

Best Regards,
Junyi
Comment 9 Guo, Zhiyi 2016-11-04 06:00:14 EDT
(In reply to Yan Vugenfirer from comment #6)
> Cannot reproduce with current QXL WDDM driver that supports Win10.

Hi Dmitry,

I cannot reproduce this issue against x86 qxl wddm driver qxlwddm-0.1-12 on windows 10 x86 guest in 10 x 8 hours reboot/boot test, do you have any suggestions to reproduce this issue?

Test iso used: en_windows_10_enterprise_version_1607_updated_jul_2016_x86_dvd_9060097.iso
en_windows_10_enterprise_x86_dvd_6851156.iso

I have tested these ios against latest 7.2.z host and latest 7.3 host.
7.2.z host env:
3.10.0-327.18.2.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.23.x86_64
seavgabios-bin-1.7.5-11.el7.noarch
seabios-bin-1.7.5-11.el7.noarch

7.3 host env:
3.10.0-512.el7.x86_64
qemu-kvm-rhev-2.6.0-28.el7.x86_64
seabios-bin-1.9.1-5.el7.noarch
seavgabios-bin-1.9.1-5.el7.noarch

qemu-cmd used on 7.2.z host:
/usr/libexec/qemu-kvm \
-name win10-old-32 \
-S \
-machine pc-i440fx-rhel7.2.0,accel=kvm,usb=off,vmport=off \
-cpu Haswell-noTSX,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff \
-m 4096 \
-realtime mlock=off \
-smp 2,sockets=2,cores=1,threads=1 \
-uuid e2f52a37-358b-4d9c-b3e8-7a7bd5e1d14c \
-no-user-config \
-nodefaults \
-chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-win10-old-32/monitor.sock,server,nowait \
-mon chardev=charmonitor,id=monitor,mode=control \
-rtc base=localtime,driftfix=slew \
-global kvm-pit.lost_tick_policy=discard \
-no-hpet \
-no-shutdown \
-global PIIX4_PM.disable_s3=1 \
-global PIIX4_PM.disable_s4=1 \
-boot strict=on \
-device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 \
-device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 \
-device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 \
-device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 \
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 \
-drive file=/home/old-win10-386.qcow2,if=none,id=drive-ide0-0-0,format=qcow2 \
-device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 \
-netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:3b:4e:70,bus=pci.0,addr=0x3 \
-chardev pty,id=charserial0 \
-device isa-serial,chardev=charserial0,id=serial0 \
-chardev spicevmc,id=charchannel0,name=vdagent \
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 \
-device usb-tablet,id=input0 \
-spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on \
-device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 \
-device intel-hda,id=sound0,bus=pci.0,addr=0x4 \
-device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 \
-chardev spicevmc,id=charredir0,name=usbredir \
-device usb-redir,chardev=charredir0,id=redir0 \
-chardev spicevmc,id=charredir1,name=usbredir \
-device usb-redir,chardev=charredir1,id=redir1 \
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 \
-msg timestamp=on

qemu cmd used on 7.3 host:
/usr/libexec/qemu-kvm \
-name guest=win10-32,debug-threads=on \
-S \
-object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-1-win10-32/master-key.aes \
-machine pc-i440fx-rhel7.3.0,accel=kvm,usb=off,vmport=off \
-cpu Haswell-noTSX \
-m 2048 \
-realtime mlock=off \
-smp 2,sockets=2,cores=1,threads=1 \
-uuid 38093767-4c97-45c7-862f-e3574b4fbb25 \
-no-user-config \
-nodefaults \
-chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-1-win10-32/monitor.sock,server,nowait \
-mon chardev=charmonitor,id=monitor,mode=control \
-rtc base=utc,driftfix=slew \
-global kvm-pit.lost_tick_policy=discard \
-no-hpet \
-no-shutdown \
-global PIIX4_PM.disable_s3=1 \
-global PIIX4_PM.disable_s4=1 \
-boot strict=on \
-device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 \
-device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 \
-device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 \
-device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 \
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 \
-drive file=/root/win10-32.qcow2,format=qcow2,if=none,id=drive-ide0-0-0 \
-device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 \
-drive file=/home/brasero.iso,format=raw,if=none,id=drive-ide0-0-1,readonly=on \
-device ide-cd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 \
-drive file=/home/blk.qcow2,format=qcow2,if=none,id=drive-virtio-disk0 \
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x8,drive=drive-virtio-disk0,id=virtio-disk0 \
-netdev tap,fd=26,id=hostnet0,vhost=on,vhostfd=28 \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:b3:e9:97,bus=pci.0,addr=0x3 \
-chardev pty,id=charserial0 \
-device isa-serial,chardev=charserial0,id=serial0 \
-chardev spicevmc,id=charchannel0,name=vdagent \
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 \
-spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on \
-device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,bus=pci.0,addr=0x2 \
-device intel-hda,id=sound0,bus=pci.0,addr=0x4 \
-device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 \
-chardev spicevmc,id=charredir0,name=usbredir \
-device usb-redir,chardev=charredir0,id=redir0,bus=usb.0,port=1 \
-chardev spicevmc,id=charredir1,name=usbredir \
-device usb-redir,chardev=charredir1,id=redir1,bus=usb.0,port=2 \
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 \
-msg timestamp=on

Please notice, I also cannot reproduce this issue agaisnt qxl wddm driver qxlwddm-0.4-1 in 7 x 8 hours with above environments.

BR/
Guo, Zhiyi
Comment 10 Dmitry Fleytman 2016-11-06 06:34:10 EST
Hello, 

We were unable to reproduce this issue either. I suggest to close it as NOT REPRODUCIBLE.

~Dmitry

Note You need to log in before you can comment on or make changes to this bug.