Bug 1253201 - [UX] Need to press twice the 'ok' button in order to initiate 'new template creation'
[UX] Need to press twice the 'ok' button in order to initiate 'new template c...
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 04:33 EDT by Ori Gofen
Modified: 2016-05-25 21:51 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-27 04:30:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Ori Gofen 2015-08-13 04:33:30 EDT
Description of problem:
When trying a template creation, need to press twice 'ok'

Version-Release number of selected component (if applicable):
3.6

How reproducible:
100%

Steps to Reproduce:
1.open 'New Template dialogue'
2.tab browse to 'ok' button
3.press enter

Actual results:
Need to press twice enter

Expected results:
One is enough

Additional info:
Comment 1 Einav Cohen 2015-08-17 08:31:04 EDT
some comments:

- this is not reproducible consistently - it reproduced for me one time, then stopped reproducing. 

- note that the dialog is working properly when:

  * clicking on the 'ok' button using the mouse. 
 
  * hitting "enter" on the keyboard without focusing on the 'OK' button first. 

the problem seems to be occurring (again, not consistently) when navigating the focus to the 'OK' button (using the 'tab' keyboard key) and hitting the 'enter' keyboard key. 

- a problem that does seem to be reproducing consistently is that when navigating the focus to the 'OK' button (using the 'tab' keyboard key) and hitting the 'enter' keyboard key, it looks like the action is being invoked twice (second one failing, as the VM's image file is already locked, resulting in a CanDoAction failure dialog).
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 06:58:46 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Moran Goldboim 2016-03-27 04:30:56 EDT
Closing this one due to capacity, and looking on different path for the future of this flow. 
if this issue keeps happening in a way that bothers functioning, please reopen.

Note You need to log in before you can comment on or make changes to this bug.