Bug 1253270 - Cannot create Docker container
Cannot create Docker container
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity high (vote)
: 6.1.2
: --
Assigned To: Partha Aji
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 07:38 EDT by Oleksandr Shtaier
Modified: 2017-02-23 14:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 15:32:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error that we get after workaround is applied (68.06 KB, image/png)
2015-08-13 07:38 EDT, Oleksandr Shtaier
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11212 None None None 2016-04-22 11:46 EDT

  None (edit)
Description Oleksandr Shtaier 2015-08-13 07:38:14 EDT
Created attachment 1062488 [details]
Error that we get after workaround is applied

Description of problem:
It is impossible to create Docker container while we have 'docker-1.7.1...' package installed

Version-Release number of selected component (if applicable):
RC1

How reproducible:
Always.

Steps to Reproduce:
1. Create new Docker compute resource (no matter using 'EXTERNAL DOCKER URL' or 'INTERNAL DOCKER URL')
2. Create Product and add Docker repository to it. (e.g. 'busybox' from 'https://registry.hub.docker.com')
3. Sync that repo (In result we should have repo with some Docker Images and some Docker Tags inside)
4. Push 'New Container' button
5. Preliminary->Deploy on->Select Docker compute resource from step 1
6. Next->Image->Content View
7. Select Lifecycle Environment (e.g. 'Library')
8. Select Content View (e.g. 'Default Organization View')
9. Select Repository from step 2
10. Select Tag (e.g. 'latest')
11. Next->Configuration
12. Input any Name (e.g. 'Container_01')
13. Input any command (e.g. 'top')
14. Next->Environment
15. Do nothing here
16. Push Submit button

WORKAROUND (so we can create container using 'Content View' tab):
Run 'yum downgrade docker*' for your sat server (it should become 1.6.2 version)

Side-effect for workaround:
You will not be able to create Docker container through 'Docker Hub' Tab
6. Next->Image->Docker Hub
7. Input any word to search (e.g. 'centos')
8. Input tag that you have in Docket Tags list (e.g. 'latest')
You will get next error on UI:
```
undefined method `info' for nil:NilClass
If you feel this is an error with Satellite 6 itself, please open a new issue with Satellite ticketing system, You would probably need to attach the Full trace and relevant log entries.

NoMethodError
undefined method `info' for nil:NilClass
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'
```

Actual results:
Getting next message in the UI:
Error creating communicating with Docker.
Check the Foreman logs: json: cannot unmarshal string into Go value of type int64

Expected results:
Container created successfully

Additional info:
Comment 2 Elyézer Rezende 2015-09-10 16:02:00 EDT
Verified on Sat6.1.2 Snap1 Compose2

Steps to verify:

1. Create new Docker compute resource (no matter using 'EXTERNAL DOCKER URL' or 'INTERNAL DOCKER URL')
2. Create Product and add Docker repository to it. (e.g. 'busybox' from 'https://registry.hub.docker.com')
3. Sync that repo (In result we should have repo with some Docker Images and some Docker Tags inside)
4. Push 'New Container' button
5. Preliminary->Deploy on->Select Docker compute resource from step 1
6. Next->Image->Content View
7. Select Lifecycle Environment (e.g. 'Library')
8. Select Content View (e.g. 'Default Organization View')
9. Select Repository from step 2
10. Select Tag (e.g. 'latest')
11. Next->Configuration
12. Input any Name (e.g. 'Container_01')
13. Input any command (e.g. 'top')
14. Next->Environment
15. Do nothing here
16. Push Submit button

Additional info:
Tested against ruby193-rubygem-foreman_docker-1.2.0.22-1.el7sat.noarch
Comment 3 Bryan Kearney 2015-09-22 15:32:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1786

Note You need to log in before you can comment on or make changes to this bug.