Bug 1253271 - ahc-report --full fails due to permission issues.
ahc-report --full fails due to permission issues.
Status: CLOSED DUPLICATE of bug 1267026
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 07:42 EDT by Sadique Puthen
Modified: 2015-09-30 22:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 22:20:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sadique Puthen 2015-08-13 07:42:25 EDT
Description of problem:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Advanced-Scenario_3_Using_the_CLI_to_Create_an_Advanced_Overcloud_with_Ceph_Nodes.html#sect-Advanced-Registering_Nodes_for_the_Advanced_Overcloud

6.3.3.1. ahc-report
The ahc-report script produces various reports about your nodes. To view a full report, use the --full option.

$ ahc-report --full

This would fail because:

$ ahc-report --full
Traceback (most recent call last):
  File "/bin/ahc-report", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/ahc_tools/report.py", line 90, in main
    CONF(args=args, default_config_files=utils.DEFAULT_CONF_FILES)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 1860, in __call__
    self._namespace._files_permission_denied)
oslo_config.cfg.ConfigFilesPermissionDeniedError: Failed to open some config files: /etc/ahc-tools/ahc-tools.conf
[stack@instack ~]$ ll /etc/ahc-tools/ahc-tools.conf
-rw-------. 1 root root 682 Aug 11 08:38 /etc/ahc-tools/ahc-tools.conf


this file is owned by root and earlier steps set permission to 600 which may be wrong to run ti as normal user later

Either we need to change the permission or run with sudo.
Comment 3 Dan Macpherson 2015-09-30 22:20:41 EDT

*** This bug has been marked as a duplicate of bug 1267026 ***

Note You need to log in before you can comment on or make changes to this bug.