This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253312 - Storage dialog design - alignment issues
Storage dialog design - alignment issues
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Vered Volansky
Kevin Alon Goldblatt
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 09:04 EDT by Pavel Stehlik
Modified: 2016-03-10 10:11 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:35:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
storage dialogue iscsi (201.52 KB, image/png)
2015-08-13 09:04 EDT, Pavel Stehlik
no flags Details
screenshot added (199.73 KB, image/png)
2015-10-27 10:07 EDT, Kevin Alon Goldblatt
no flags Details

  None (edit)
Description Pavel Stehlik 2015-08-13 09:04:36 EDT
Created attachment 1062530 [details]
storage dialogue iscsi

Description of problem:
 "Advanced parameters" is covering LUNs part - see att. image (described there as "1.")
Also the rectangle shown as "2." in image is somehow cut (the very bottom line is missing).


Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.11.master.el6.noarch
FF 39

How reproducible:


Steps to Reproduce:
1. try to open Storage dialogue for adding new iSCSI lun 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vered Volansky 2015-09-07 05:01:28 EDT
Pavel,

I was not able to reproduce (New iscsi sd).
This is aligned for me in both FF 37.0.2 and FF 26.0 .
What browser/version were you using?
What commit?

Thanks,
Vered
Comment 2 Vered Volansky 2015-09-09 05:25:23 EDT
> This is aligned for me in both FF 37.0.2 and FF 26.0 .

The same goes for FF40.
3.6.0-0.13.master.el6.

Please re-check with the above version.

Einav,
If this is indeed an issue in FF39 and not in 37 or 40 - is this something we want to support?
Comment 3 Einav Cohen 2015-09-09 11:38:29 EDT
(In reply to Vered Volansky from comment #2)
> > This is aligned for me in both FF 37.0.2 and FF 26.0 .
> 
> The same goes for FF40.
> 3.6.0-0.13.master.el6.
> 
> Please re-check with the above version.

+1
there is a good chance that the issue reported in bug 1254179 and several other bugs has affected several locations and behaviours in the UI. 

> 
> Einav,
> If this is indeed an issue in FF39 and not in 37 or 40 - is this something
> we want to support?

my assumption that FF37, 39 and 40 are actually behaving similarly in that sense - it is really a matter of testing rhevm-3.6.0-0.11 vs a newer version. 
in any case - we are always focusing on the latest FF ESR version (about to become FF38 for us), not other FF versions.
Comment 4 Kevin Alon Goldblatt 2015-10-27 10:04:16 EDT
Code used to verify this bz:
--------------------------------
rhevm-3.6.0-0.18.el6.noarch
vdsm-4.17.8-1.el7ev.noarch

Scenario used to verify this bz:
--------------------------------
Steps to reproduce:

1. Via the Web admin -> open Storage dialogue for adding new iSCSI lun
2. Navigate to "Advanced parameters" >>>>> The "Advance Parameters" text is no longer covering LUNs text - see att. image 
Also the rectangle (border) is now complete
Added Screen shot of new correctly alligned dialogue
Comment 5 Kevin Alon Goldblatt 2015-10-27 10:07 EDT
Created attachment 1086856 [details]
screenshot added

Adding screen shot of correctly aligned dialogue
Comment 6 Sandro Bonazzola 2015-11-04 08:35:46 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.