Bug 125333 - Cannot build QT SRPM when buildstatic = 1
Cannot build QT SRPM when buildstatic = 1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 15:36 EDT by Torin Ford
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 07:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torin Ford 2004-06-04 15:36:17 EDT
Description of problem:
The source RPM for QT has a flag called buildstatic that says when it 
is set to true (1), it will build the static version(s) of the 
packages.  Unfortunately this does not work.

Version-Release number of selected component (if applicable):
qt-3.3.2

How reproducible:
Always

Steps to Reproduce:
1.  Install qt-3.3.2-2.src.rpm
2.  Open /usr/src/redhat/SPECS/qt.spec
3.  Change %define buildstatic 0 to %define buildstatic 1
4.  Save and close /usr/src/redhat/SPECS/qt.spec
5.  Run rpmbuild -ba /usr/src/redhat/SPECS/qt.spec
  
Actual results:
Build process fails as such:

+ /usr/lib/rpm/find-debuginfo.sh /usr/src/redhat/BUILD/qt-x11-free-
3.3.2
extracting debug info from /var/tmp/qt-root/usr/lib/qt-3.3/bin/qmake
extracting debug info from /var/tmp/qt-root/usr/lib/qt-3.3/bin/moc
extracting debug info from /var/tmp/qt-root/usr/lib/qt-3.3/bin/uic
extracting debug info from /var/tmp/qt-root/usr/lib/qt-
3.3/bin/designer
extracting debug info from /var/tmp/qt-root/usr/lib/qt-
3.3/bin/assistant
extracting debug info from /var/tmp/qt-root/usr/lib/qt-
3.3/bin/linguist
extracting debug info from /var/tmp/qt-root/usr/lib/qt-
3.3/bin/lrelease
extracting debug info from /var/tmp/qt-root/usr/lib/qt-3.3/bin/lupdate
extracting debug info from /var/tmp/qt-root/usr/lib/qt-3.3/bin/qm2ts
extracting debug info from /var/tmp/qt-root/usr/lib/qt-
3.3/bin/qtconfig
cpio: qt-x11-free-3.3.2/src/moc/lex.yy.c: No such file or directory
cpio: qt-x11-free-3.3.2/src/moc/y.tab.c: No such file or directory
15464 blocks
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-
note /usr/bin/strip /usr/bin/objdump
/etc/security/selinux/file_contexts: No such file or directory
Processing files: qt-3.3.2-2
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/lib/libqt*.so.*
error: File not found: /var/tmp/qt-root/usr/lib/qt-3.3/plugins
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/lib/libqui.so.*
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.5722
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd qt-x11-free-3.3.2
+ DOCDIR=/var/tmp/qt-root/usr/share/doc/qt-3.3.2
+ export DOCDIR
+ rm -rf /var/tmp/qt-root/usr/share/doc/qt-3.3.2
+ /bin/mkdir -p /var/tmp/qt-root/usr/share/doc/qt-3.3.2
+ cp -pr FAQ LICENSE.QPL README README-QT.TXT changes-
3.3.2 /var/tmp/qt-root/usr/share/doc/qt-3.3.2
+ exit 0
Processing files: qt-devel-3.3.2-2
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/lib/libqt*.so
error: File not found: /var/tmp/qt-root/usr/lib/qt-3.3/lib/libqui.so
error: File not found: /var/tmp/qt-root/usr/lib/qt-3.3/lib/libeditor.a
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.5722
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd qt-x11-free-3.3.2
+ DOCDIR=/var/tmp/qt-root/usr/share/doc/qt-devel-3.3.2
+ export DOCDIR
+ rm -rf /var/tmp/qt-root/usr/share/doc/qt-devel-3.3.2
+ /bin/mkdir -p /var/tmp/qt-root/usr/share/doc/qt-devel-3.3.2
+ cp -pr doc/3rdparty.doc doc/aboutqt.doc doc/accel.doc 
doc/annotated.doc doc/appicon.doc doc/application-walkthrough.doc 
doc/canvas.doc doc/changes.doc doc/charinp
ut-qws.doc doc/classchart.doc doc/classes.doc doc/collect.doc 
doc/commercialeditions.doc doc/coordsys.doc doc/credits.doc 
doc/customstyles.doc doc/datastreamformat.
doc doc/debug.doc doc/distributingqt.doc doc/dnd.doc doc/editions.doc 
doc/embclasses.doc doc/embporting.doc doc/envvars.doc doc/faq.doc 
doc/features.doc doc/focus.d
oc doc/framebuffer-howto.doc doc/freeeditions.doc doc/functions.doc 
doc/headers.doc doc/hierarchy.doc doc/how-to-learn-qt.doc doc/html 
doc/i18n.doc doc/indices.doc 
doc/installation.doc doc/integration.doc doc/layout.doc doc/mac.doc 
doc/Makefile doc/makeqpf.doc doc/metaobjects.doc doc/misc.doc 
doc/moc.doc doc/modules.doc doc/ne
twork.doc doc/networking.doc doc/object.doc doc/opengl-x11-
overlays.doc doc/overviews-list.doc doc/pictures.doc doc/plugins-
howto.doc doc/porting2.doc doc/porting3.
doc doc/primes.doc doc/qasciicache.doc doc/qasciidict.doc 
doc/qcache.doc doc/qcollection-compat.doc doc/qdict.doc 
doc/qembed.doc doc/qguardedptr.doc doc/qintcache.d
oc doc/qintdict.doc doc/qmap.doc doc/qmemarray.doc 
doc/qobjectlist.doc doc/qpair.doc doc/qptrdict.doc doc/qptrlist.doc 
doc/qptrqueue.doc doc/qptrstack.doc doc/qptrv
ector.doc doc/qsortedlist.doc doc/qtl.doc doc/qtmac-as-native.doc 
doc/qvaluelist.doc doc/qvaluestack.doc doc/qvaluevector.doc 
doc/qvfb.doc doc/qws.doc doc/session.d
oc doc/shclass.doc doc/signalsandslots.doc doc/sql.doc doc/sql-
driver.doc doc/table.doc doc/threads.doc doc/tools-list.doc 
doc/trademarks.doc doc/tutorial2.doc doc/
tutorial.doc doc/uic.doc doc/unicode.doc doc/winsystem.doc 
doc/xml.doc doc/xml-sax-features-walkthrough.doc doc/xml-sax-
walkthrough.doc doc/y2k.doc /var/tmp/qt-root
/usr/share/doc/qt-devel-3.3.2
+ cp -pr examples.tar.bz2 /var/tmp/qt-root/usr/share/doc/qt-devel-
3.3.2
+ exit 0
Processing files: qt-ODBC-3.3.2-2
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/sqldrivers/libqsqlodbc*
Processing files: qt-MySQL-3.3.2-2
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/sqldrivers/libqsqlmysql*
Processing files: qt-PostgreSQL-3.3.2-2
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/sqldrivers/libqsqlpsql*
Processing files: qt-static-3.3.2-2
/etc/security/selinux/file_contexts: No such file or directory
Provides: qt3-static
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib
(PayloadFilesHavePrefix) <= 4.0-1
Requires: qt-devel = 1:3.3.2-2
Obsoletes: qt3-static
Processing files: qt-designer-3.3.2-2
error: File not found: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/designer
error: File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/designer/*
Processing files: qt-debuginfo-3.3.2-2
/etc/security/selinux/file_contexts: No such file or directory
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib
(PayloadFilesHavePrefix) <= 4.0-1


RPM build errors:
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/lib/libqt*.so.*
    File not found: /var/tmp/qt-root/usr/lib/qt-3.3/plugins
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/lib/libqui.so.*
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/lib/libqt*.so
    File not found: /var/tmp/qt-root/usr/lib/qt-3.3/lib/libqui.so
    File not found: /var/tmp/qt-root/usr/lib/qt-3.3/lib/libeditor.a
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/sqldrivers/libqsqlodbc*
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/sqldrivers/libqsqlmysql*
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/sqldrivers/libqsqlpsql*
    File not found: /var/tmp/qt-root/usr/lib/qt-3.3/plugins/designer
    File not found by glob: /var/tmp/qt-root/usr/lib/qt-
3.3/plugins/designer/*

Expected results:
All RPMs (or at least qt-static) are built properly.

Additional info:
Comment 1 Ngo Than 2004-06-24 07:15:18 EDT
i did not provide static qt library since RHL8.

please don't use this macro buildstatic, it will be removed in next
rebuild.

Note You need to log in before you can comment on or make changes to this bug.