Bug 1253348 - [abrt] evolution: gal_a11y_e_cell_popup_new(): evolution killed by SIGSEGV
[abrt] evolution: gal_a11y_e_cell_popup_new(): evolution killed by SIGSEGV
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:87ac97e781ba39f948e48e498e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 10:18 EDT by Martin Gregorie
Modified: 2015-08-14 07:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 07:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (63.85 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: cgroup (177 bytes, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: core_backtrace (11.00 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: dso_list (27.96 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: environ (3.82 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: maps (84.35 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: mountinfo (3.17 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: open_fds (3.93 KB, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: proc_pid_status (879 bytes, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details
File: var_log_messages (310 bytes, text/plain)
2015-08-13 10:18 EDT, Martin Gregorie
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 358162 None None None Never
GNOME Desktop 753609 None None None Never

  None (edit)
Description Martin Gregorie 2015-08-13 10:18:22 EDT
Description of problem:
Steps to Reproduce:
1. Select the Tasks list
2. Attempt to add a new task to the list

Selecting the date box brings up the date selector, and allows a date to be selected, but any attempt to enter the date leaves the date box blank. Typing a date into the box also leaves the date box blank when Enter or TAB have been hit.
After a few tries Evolution crashes.

Similarly, entering the task description first and then clicking the date box immediately wipes out the description. I can't say definitely if this also causes a crash. However, I've seen several crashes I *know* were related to trying to enter a date.

Version-Release number of selected component:
evolution-3.16.4-2.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        evolution
crash_function: gal_a11y_e_cell_popup_new
executable:     /usr/bin/evolution
global_pid:     12619
kernel:         4.1.3-201.fc22.i686+PAE
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (4 frames)
 #0 gal_a11y_e_cell_popup_new at gal-a11y-e-cell-popup.c:101
 #1 gal_a11y_e_cell_registry_get_object at gal-a11y-e-cell-registry.c:136
 #2 eti_ref_at at gal-a11y-e-table-item.c:414
 #3 eti_a11y_reset_focus_object at gal-a11y-e-table-item.c:242

Potential duplicate: bug 1214317
Comment 1 Martin Gregorie 2015-08-13 10:18:28 EDT
Created attachment 1062614 [details]
File: backtrace
Comment 2 Martin Gregorie 2015-08-13 10:18:29 EDT
Created attachment 1062615 [details]
File: cgroup
Comment 3 Martin Gregorie 2015-08-13 10:18:31 EDT
Created attachment 1062616 [details]
File: core_backtrace
Comment 4 Martin Gregorie 2015-08-13 10:18:33 EDT
Created attachment 1062617 [details]
File: dso_list
Comment 5 Martin Gregorie 2015-08-13 10:18:34 EDT
Created attachment 1062618 [details]
File: environ
Comment 6 Martin Gregorie 2015-08-13 10:18:35 EDT
Created attachment 1062619 [details]
File: limits
Comment 7 Martin Gregorie 2015-08-13 10:18:39 EDT
Created attachment 1062620 [details]
File: maps
Comment 8 Martin Gregorie 2015-08-13 10:18:40 EDT
Created attachment 1062621 [details]
File: mountinfo
Comment 9 Martin Gregorie 2015-08-13 10:18:41 EDT
Created attachment 1062622 [details]
File: namespaces
Comment 10 Martin Gregorie 2015-08-13 10:18:42 EDT
Created attachment 1062623 [details]
File: open_fds
Comment 11 Martin Gregorie 2015-08-13 10:18:44 EDT
Created attachment 1062624 [details]
File: proc_pid_status
Comment 12 Martin Gregorie 2015-08-13 10:18:45 EDT
Created attachment 1062625 [details]
File: var_log_messages
Comment 13 Milan Crha 2015-08-14 04:15:23 EDT
Thanks for a bug report. I'm not able to reproduce the crash, but I see the issue with vanished user data in the "inline" editing in the task list. I filled bug [1] for it. Please see it for any further updates in this part.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=753609
Comment 14 Milan Crha 2015-08-14 07:56:32 EDT
I managed to reproduce the crash too, I'm moving this upstream as well. Please see [2] for any further updates.

[2] https://bugzilla.gnome.org/show_bug.cgi?id=358162

Note You need to log in before you can comment on or make changes to this bug.