Bug 125346 - lsof doesn't show deleted maps correctly under kernel-2.6.5-1.358 and kernel-2.6.6-1.427
Summary: lsof doesn't show deleted maps correctly under kernel-2.6.5-1.358 and kernel-...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-04 22:18 UTC by Jordan Russell
Modified: 2015-01-04 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 17:31:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results of lsof on each kernel (2.81 KB, text/plain)
2004-06-04 22:22 UTC, Jordan Russell
no flags Details

Description Jordan Russell 2004-06-04 22:18:58 UTC
Description of problem:
When you run "lsof" on kernel-2.6.5-1.358 after upgrading an RPM
containing shared libraries that were in use, it doesn't show the
libraries that were replaced as unlinked mapped files ("DEL"); instead
it displays them as regular files ("REG"). This problem does not exist
when lsof is run on a stock 2.6.6 kernel.

Version-Release number of selected component (if applicable):
lsof-4.68-2

How reproducible:
Always

Steps to Reproduce:
1. See who's using libk5crypto.so.3.0.

# lsof | fgrep /usr/lib/libk5crypto.so.3.0

2. Upgrade the krb5-* packages to a new version.

# rpm -Fvh krb5-{libs,devel}-1.3.3-7.i386.rpm

3. Immediately after upgrading the shared libraries, again see who's
using libk5crypto.so.3.0.

# lsof | fgrep /usr/lib/libk5crypto.so.3.0

Actual Results:  
With kernel-2.6.5-1.358, the second lsof prints "REG" in the type
column. This is wrong since the file was unlinked/replaced, and the
daemons using the file were never restarted.

Expected Results:
With a stock 2.6.6 kernel, the second lsof prints "DEL" in the type
column, indicating an unlinked mapped file. This is correct.

Comment 1 Jordan Russell 2004-06-04 22:22:29 UTC
Created attachment 100881 [details]
Results of lsof on each kernel

Comment 2 Jordan Russell 2004-06-11 19:46:14 UTC
Update:

The problem also exists on kernel-2.6.6-1.427 and stock 2.6.7-rc3.

Again, stock 2.6.6 works fine.

Comment 3 Dave Jones 2004-11-27 20:22:00 UTC
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?


Comment 4 Dave Jones 2004-11-27 20:22:09 UTC
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?


Comment 5 Jordan Russell 2004-12-08 17:31:14 UTC
I can no longer reproduce the problem with 2.6.9 on FC 3. Appears
either the kernel or the FC upgrade fixed this.


Note You need to log in before you can comment on or make changes to this bug.