Bug 1253526 - Increase the MySQL max_connections on the undercloud
Increase the MySQL max_connections on the undercloud
Status: CLOSED DUPLICATE of bug 1243600
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
Director
x86_64 Linux
unspecified Severity medium
: ---
: Director
Assigned To: chris alfonso
yeylon@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 22:22 EDT by Gaëtan Trellu
Modified: 2016-04-18 02:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 01:25:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaëtan Trellu 2015-08-13 22:22:16 EDT
Description of problem:

During an Heat stack deletion, the stack failed and we are unable to remove it even after many retries.
We can see MySQL max_connection errors in the Heat logs:

   OperationalError: (_mysql_exceptions.OperationalError) (1040, 'Too many connections')\n"]."

The full log is in the "Additional info" section.

After raised the max_connections to 2048, I was able to delete the Heat stack.

Version-Release number of selected component (if applicable):

rhos-release-0.66-1.noarch
python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch
puddle images 2015-07-30.1

How reproducible:

It can be reproduce with big Heat stack, like 10 nodes to deploy.

Steps to Reproduce:
1. Heat stack deployment
2. Heat stack deletion

Actual results:

Unable to delete the Heat stack even after many retries.

Expected results:

Be able to delete an Heat stack without error.

Additional info:

Heat error logs: http://pastebin.test.redhat.com/305355
Comment 3 Mike Burns 2015-08-14 01:25:05 EDT

*** This bug has been marked as a duplicate of bug 1243600 ***

Note You need to log in before you can comment on or make changes to this bug.