This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 125357 - [TEXT MODE] Not allowed to 'Change Boot Order' for MBR install
[TEXT MODE] Not allowed to 'Change Boot Order' for MBR install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 21:02 EDT by Chris Rainey
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 22:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Rainey 2004-06-04 21:02:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040117

Description of problem:
Not allowed to 'Change Boot Order' to avoid having Grub install to the
MBR of an incorrect drive(i.e. SCSI/IDE combo where BIOS switches to
SDA on boot as first-disk, yet Grub installs to MBR of IDE drive(ASUS
P2B-S using aic7xxx controller)).  This is not a problem with the
Graphical install since you are given this option to change boot-order
from the Advanced screen of the Boot Loader section.

Obviously, I prefer the Text-Mode install since it takes less time
over FTP to load and I am faster at keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Advance through text-mode install to choice of which drive to
install MBR onto.
2. If an IDE drive is present and detected as the 'first' device, then
not able to manually override as BIOS will upon next boot.
3.
    

Actual Results:  Not able to select 'sda' instead  'hdd' , etc...

Expected Results:  Option to change boot-order like in Advanced
section of Graphical installer MBR choices.

Additional info:
Comment 1 Jeremy Katz 2004-06-04 22:27:29 EDT
The text mode install is only for cases where it's necessary and not
the primary and preferred form of installation.  It's not going to
support all of the same features as the graphical installation.

Note You need to log in before you can comment on or make changes to this bug.