Bug 1253595 - lazytime mount option doesn't work on root partition
lazytime mount option doesn't work on root partition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 04:20 EDT by srakitnican
Modified: 2015-08-19 10:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 10:53:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description srakitnican 2015-08-14 04:20:18 EDT
Description of problem: By adding lazytime mount option to fstab and rebooting, mount command shows lazytime applied only to /home partition, not on /. Moreover changing mount options on mounted partitions described in following mail using mount -o remount command does not work at all.

http://www.spinics.net/lists/linux-fsdevel/msg86233.html

Version-Release number of selected component (if applicable):
util-linux-2.26.2-1.fc22.x86_64
kernel-4.1.3-201.fc22.x86_64


How reproducible: Always


Steps to Reproduce:
1. Add lazytime option to /etc/fstab
2. Reboot

Actual results: lazytime applied only to /home 


Expected results: lazytime applied on both /home and / partitions


Additional info:
Comment 1 Josh Boyer 2015-08-17 11:09:52 EDT
(In reply to semiRocket from comment #0)
> Description of problem: By adding lazytime mount option to fstab and
> rebooting, mount command shows lazytime applied only to /home partition, not
> on /. 

> Moreover changing mount options on mounted partitions described in
> following mail using mount -o remount command does not work at all.

http://article.gmane.org/gmane.comp.file-systems.ext4/48663

suggests that the remount issue is a regression in util-linux.  You should probably file a separate bug against that component to get it fixed.

> 
> http://www.spinics.net/lists/linux-fsdevel/msg86233.html
> 
> Version-Release number of selected component (if applicable):
> util-linux-2.26.2-1.fc22.x86_64
> kernel-4.1.3-201.fc22.x86_64
> 
> 
> How reproducible: Always
> 
> 
> Steps to Reproduce:
> 1. Add lazytime option to /etc/fstab
> 2. Reboot

Did you specify rootflags=lazytime on the kernel command line or did you rebuild your initramfs after updating /etc/fstab?
Comment 2 srakitnican 2015-08-18 21:42:36 EDT
(In reply to Josh Boyer from comment #1)
> (In reply to semiRocket from comment #0)
> > Description of problem: By adding lazytime mount option to fstab and
> > rebooting, mount command shows lazytime applied only to /home partition, not
> > on /. 
> 
> > Moreover changing mount options on mounted partitions described in
> > following mail using mount -o remount command does not work at all.
> 
> http://article.gmane.org/gmane.comp.file-systems.ext4/48663
> 
> suggests that the remount issue is a regression in util-linux.  You should
> probably file a separate bug against that component to get it fixed.
 
Did that: https://bugzilla.redhat.com/show_bug.cgi?id=1254833
 
> Did you specify rootflags=lazytime on the kernel command line or did you
> rebuild your initramfs after updating /etc/fstab?

I did not do any of that because I thought that will work as is. With rootflags=lazytime at boot time works, did not try to rebuild initramfs.
Comment 3 Josh Boyer 2015-08-19 10:53:24 EDT
(In reply to semiRocket from comment #2)
> (In reply to Josh Boyer from comment #1)
> > (In reply to semiRocket from comment #0)
> > > Description of problem: By adding lazytime mount option to fstab and
> > > rebooting, mount command shows lazytime applied only to /home partition, not
> > > on /. 
> > 
> > > Moreover changing mount options on mounted partitions described in
> > > following mail using mount -o remount command does not work at all.
> > 
> > http://article.gmane.org/gmane.comp.file-systems.ext4/48663
> > 
> > suggests that the remount issue is a regression in util-linux.  You should
> > probably file a separate bug against that component to get it fixed.
>  
> Did that: https://bugzilla.redhat.com/show_bug.cgi?id=1254833
>  
> > Did you specify rootflags=lazytime on the kernel command line or did you
> > rebuild your initramfs after updating /etc/fstab?
> 
> I did not do any of that because I thought that will work as is. With
> rootflags=lazytime at boot time works, did not try to rebuild initramfs.

The initramfs mounts the root filesystem, so if the fstab containted within does not have the flag set it will not mount the rootfs with it unless rootflags= is specified.  I believe on future kernel updates, dracut will read /etc/fstab and pick up the options for the corresponding initramfs.

Note You need to log in before you can comment on or make changes to this bug.