Bug 125365 - "Korean" or "Japanese" added in Keyboard Preferences's layouts, popup error dialog window appear.
"Korean" or "Japanese" added in Keyboard Preferences's layouts, popup error d...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 130153 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-05 02:41 EDT by sangu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 02:53:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (37.51 KB, text/plain)
2004-06-05 02:45 EDT, sangu
no flags Details
xorg.conf (2.79 KB, text/plain)
2004-06-05 02:52 EDT, sangu
no flags Details

  None (edit)
Description sangu 2004-06-05 02:41:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.5

Description of problem:
Adding keyboard layout(Korean or Japanese), error dialog appear.

Version-Release number of selected component (if applicable):
control-center-2.6.1-3

How reproducible:
Always

Steps to Reproduce:
1. execute gnome-keyboard-properties
2. Click Layouts tab menu.
3. Add Korean or Japanese.
    

Actual Results:  Popup error dialog
Please see :
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=99545&action=view

/var/log/Xorg.0.log
[...]
(EE) Error loading keymap /usr/X11R6/lib/X11/xkb/compiled/server-0.xkm


Expected Results:  No error dialog.

Additional info:

xorg-x11-6.7.0-3, libxklavier-1.02-1
Comment 1 sangu 2004-06-05 02:45:47 EDT
Created attachment 100891 [details]
Xorg.0.log
Comment 2 sangu 2004-06-05 02:52:53 EDT
Created attachment 100892 [details]
xorg.conf
Comment 3 Timothy Riordan 2004-06-16 00:21:04 EDT
I am getting the same error..

[root@triordan1 xkb]# setxkbmap -rules xorg -layout fr -v
Warning! Multiple definitions of rules file
         Using command line, ignoring X server
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Trying to build keymap using the following components:
keycodes:   xfree86+aliases(azerty)
types:      complete
compat:     complete
symbols:    pc/pc(pc105)+pc/fr
geometry:   pc(pc105)

********************************************

[root@triordan1 xkb]# setxkbmap -rules xorg -layout ko -v
Warning! Multiple definitions of rules file
         Using command line, ignoring X server
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Trying to build keymap using the following components:
keycodes:   xfree86+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc/pc(pc105)+pc/ko
geometry:   pc(pc105)
Error loading new keyboard description

**************************************

I was sure to add the fonts in the installer but this is what I get.
Initially I thought it was the xorg/xfree86 bug till I tried french
for the heck of it. Even though I did the install for Korean as a
second language if I look at /usr/X11R6/lib/X11/xkb/symbols.dir I dont
see ko..

If anyone knows how to fix this it would be appreciated..
Comment 4 Timothy Riordan 2004-06-16 01:31:38 EDT
Turns out I am missing /usr/X11R6/lib/X11/xkb/symbols/ko

dont where to get it or if I am missing more..
Comment 5 sangu 2004-09-19 13:17:14 EDT
This problem still happens in control-center-2.7.1-3.

Additional information : 

xorg-x11-6.8.0-4
Comment 6 sangu 2004-09-22 23:56:16 EDT
This problem still happens in xorg-x11-6.8.1-3.

Please see: http://bugzilla.gnome.org/show_bug.cgi?id=137438
Comment 7 sangu 2004-09-23 00:11:56 EDT
Please See Also : http://freedesktop.org/bugzilla/show_bug.cgi?id=606
Comment 8 Mike A. Harris 2004-10-12 02:53:23 EDT
Status update:

We are now tracking this issue in X.Org bugzilla at:
    http://freedesktop.org/bugzilla/show_bug.cgi?id=606

For anyone experiencing this issue, please use the X.Org bug
above for all status updates, etc.


Setting status to "UPSTREAM" for tracking.
Comment 9 Marco Pesenti Gritti 2004-11-04 08:20:49 EST
*** Bug 130153 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.