Bug 1253677 - Storage Activation error Dumped during RHEL 6.6 Installation
Storage Activation error Dumped during RHEL 6.6 Installation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.6
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 08:38 EDT by anant
Modified: 2015-08-27 10:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 10:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ananconda logs attached (290.44 KB, application/x-gzip)
2015-08-14 08:38 EDT, anant
no flags Details
anaconda log files (9.74 KB, text/plain)
2015-08-17 00:50 EDT, anant
no flags Details
anaconda exception report (1.59 MB, text/plain)
2015-08-17 00:58 EDT, anant
no flags Details
storage logs (1006.53 KB, text/plain)
2015-08-17 01:08 EDT, anant
no flags Details
anaconda program log files (274.53 KB, text/plain)
2015-08-17 01:43 EDT, anant
no flags Details
syslog of anaconda environment (155.88 KB, text/plain)
2015-08-17 01:44 EDT, anant
no flags Details

  None (edit)
Description anant 2015-08-14 08:38:01 EDT
Created attachment 1063010 [details]
Ananconda logs attached

Description of problem:

I was performing RHEL6.6 Installation on  a server.

While installation, I saw error of below title:-

An error was encountered while activating your storage configuration

mdactivate failed for /dev/md8: 02:01:53,589 ERROR   : 

mdadm: no recogniseable superblock on /dev/sdl1



Version-Release number of selected component (if applicable):
RHEL 6.6 


How reproducible:
Re-installation of system 


Steps to Reproduce:
Installation with RHEL 6.6 ISO 

Actual results:

Installation failure with mdactivate function.  

Expected results:

Installation should continue and complete successfully.

Additional info:
When I reboot the system 1-2 times and then try Installation, This issue does not reproduce 

Below is the traces of anaconda exception report:-   


anaconda 13.21.229 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/mdraid.py", line 201, in mdactivate
    raise MDRaidError("mdactivate failed for %s: %s" % (device, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 3079, in setup
    uuid=self.uuid)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 319, in execute
    self.device.setup(orig=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 721, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 233, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/text.py", line 602, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1139, in <module>
    anaconda.intf.run(anaconda)
MDRaidError: mdactivate failed for /dev/md8: 02:01:53,589 ERROR   : mdadm: no recogniseable superblock on /dev/sdl1
Comment 2 anant 2015-08-14 09:01:13 EDT
Hi,

Please let me know in case more information or data is needed.
Comment 3 anant 2015-08-17 00:50:50 EDT
Created attachment 1063607 [details]
anaconda log files

Attached anaconda.log
Comment 4 anant 2015-08-17 00:58:48 EDT
Created attachment 1063609 [details]
anaconda exception report

anaconda exception report attached
Comment 5 anant 2015-08-17 01:08:41 EDT
Created attachment 1063611 [details]
storage logs

anaconda storage logs
Comment 6 anant 2015-08-17 01:43:16 EDT
Created attachment 1063625 [details]
anaconda program log files

program.log file attached
Comment 7 anant 2015-08-17 01:44:20 EDT
Created attachment 1063626 [details]
syslog of anaconda environment

Attaching the syslog of anaconda installation environment
Comment 8 anant 2015-08-17 01:46:24 EDT
HI All,

I attached individuals logs from installation environment.
Same logs are also present in the anaconda_logs.tar.gz attached in this issue

Please let me know if any other information is required from me
Comment 9 anant 2015-08-21 06:34:49 EDT
HI Anaconda-Team,

Request you to look into this issue.
Please provide your input.


I found that the message display error that 
no recogniseable superblock on /dev/sdl1
no recogniseable superblock on /dev/sdb1

But /dev/sdb1 and /dev/sdl1 seems to be accessible normally.

Can you, please suggest a input related to this issue
Comment 10 anant 2015-08-21 08:05:43 EDT
Hi All,

One more observation that I want to confirm(May be I am wrong).

I checked the logs and found that mdadm --assemble command has failed. 
But why it(anaconda) calls mdadm --assemble command, But I think it should instead call mdadm --create because I am performing a  fresh installation.


Also when I reboot system and re performs the installation , and then whenever the installation completes successfully , mdadm create command is called instead of assemble.

Please check if this information can  help to help understood this issue more.
Comment 11 anant 2015-08-25 01:25:41 EDT
Hi RHEL Installer-Team, 

My understanding is that issue comes whenever anaconda runs mdadm assemble for  and this issue does not comes when installer runs mdadm create for this. 

I checked the source of storage library and found that mdcreate function is responsible for creating s/w raids 

And mdactivate function uses to assemble s/w raids.

Can you please suggest me a way so that rhel installer always runs
Comment 12 anant 2015-08-25 01:28:43 EDT
Hi Installer-Team,

I want to confirm that is it possible that via option installer always create s/w raids rather than assemble them.

Request you to please help if you have a relevant information for the above behavior of rhel installer
Comment 13 Samantha N. Bueno 2015-08-25 10:39:45 EDT
While Red Hat welcomes bug reports on Red Hat products here in our
public bugzilla database, please keep in mind that bugzilla is not
a support tool or means of accessing support.  If you would like
technical support please visit our support portal at
access.redhat.com or call us for information on subscription
offerings to suit your needs.
Comment 14 anant 2015-08-27 10:02:54 EDT
Actually I am just a newbie to rhel Installer and I was initially surprised and interested in this behavior of anaconda installer.
So I thought of writting mail to devel list(Ref. below mail), with a hope that maybe somebody knows about the same.



---------- Forwarded message ----------
From: anant garg <garginfo158@gmail.com>
Date: Fri, Aug 14, 2015 at 6:28 PM
Subject: Re: Storage Activation error Dumped during RHEL 6.6 Installation
To: Discussion of Development and Customization of the Red Hat Linux Installer <anaconda-devel-list@redhat.com>



HI Vratislav,

Thank you for your response and suggestion.
I created a bug at below for tracking of this issue :-

https://bugzilla.redhat.com/show_bug.cgi?id=1253677


Thanks and Regards,
Anant Garg 


On Fri, Aug 14, 2015 at 4:46 PM, Vratislav Podzimek <vpodzime@redhat.com> wrote:
On Mon, 2015-08-10 at 13:36 +0530, anant garg wrote:
> Hi All,
>
> Does anybody knew about the above behavior of RHEL6.6  Installer.
> Please help if you have information about the above behavior.
Please file a bug at http://bugzilla.redhat.com and attach all the logs from the
installation there.

--
Vratislav Podzimek

Anaconda Rider | Red Hat, Inc. | Brno - Czech Republic

_______________________________________________
Anaconda-devel-list mailing list
Anaconda-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/anaconda-devel-list

On Mon, Aug 10, 2015 at 1:36 PM, anant garg <garginfo158@gmail.com> wrote:
Hi All,

Does anybody knew about the above behavior of RHEL6.6  Installer.
Please help if you have information about the above behavior.


Also i investigated more from anaconda program.log  and found that command( mdadm asemble) has failed from anaconda mdraid's mdactivate function :-


Below is snippet from anaconda progrm.log :-

02:01:53,585 INFO : Running... ['mdadm', '--assemble', '/dev/md8', '--uuid=1a09565d:1e048978:ab559ea5:c7753fbf', '--run', '--auto=md', '/dev/sdb1', '/dev/
sdl1']
02:01:53,589 ERROR   : mdadm: no recogniseable superblock on /dev/sdb1 
02:01:53,589 ERROR : mdadm: no recogniseable superblock on /dev/sdl1


I doubt how a reboot(2-3 times) and then try installation makes the above problem solve.

Please feel free to contact me in case you need more information.
Please help me if you have information.
 


On Mon, Aug 3, 2015 at 3:53 PM, anant garg <garginfo158@gmail.com> wrote:
Hi All,

Greetings for the day.

I have some servers which I used occasionally for Installation.

I was performing RHEL6.6 Installation on  a server.

While installation, I saw error of below title:-

An error was encountered while activating your storage configuration

mdactivate failed for /dev/md8: 02:01:53,589 ERROR   : 

mdadm: no recogniseable superblock on /dev/sdl1


I checked the exception report, It says below:-

anaconda 13.21.229 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/mdraid.py", line 201, in mdactivate
    raise MDRaidError("mdactivate failed for %s: %s" % (device, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 3079, in setup
    uuid=self.uuid)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 319, in execute
    self.device.setup(orig=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 721, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 233, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/text.py", line 602, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1139, in <module>
    anaconda.intf.run(anaconda)
MDRaidError: mdactivate failed for /dev/md8: 02:01:53,589 ERROR   : mdadm: no recogniseable superblock on /dev/sdl1

I checked the system but  found that /dev/sdl1 was accessible normally.

Also when I reboot system two-three times and then start Installation this problem does not occurs.

So This problem does not always occur, but occurs very frequently.

Does anybody have an Idea to fix it. Please help in such case 

Please let me know if you need more information .

Thanks and Regards,
Anant Garg
-------------------------------------------------------

So from the devel list, I got a response to raise a issue at bugzilla. 
So I raised a issue at bugzilla :(
Anyway thanks for your response.

Note You need to log in before you can comment on or make changes to this bug.