Bug 1253768 - "ceph-deploy rgw create" fails with "Unit ceph-radosgw.service failed to load: No such file or directory" [NEEDINFO]
"ceph-deploy rgw create" fails with "Unit ceph-radosgw.service failed to load...
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3.4
Assigned To: Boris Ranto
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 12:11 EDT by Vasu Kulkarni
Modified: 2018-02-20 15:56 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-20 15:56:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
flucifre: needinfo? (vakulkar)


Attachments (Terms of Use)

  None (edit)
Description Vasu Kulkarni 2015-08-14 12:11:07 EDT
Description of problem:

ceph-deploy rgw create command is failing with
 Unit ceph-radosgw.service failed to load: No such file or directory
2015-08-13T22:41:50.895 INFO:teuthology.orchestra.run.magna087:Running: 'cd ~/cdtest ; ceph-deploy rgw create magna087'
2015-08-13T22:41:51.115 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.conf][DEBUG ] found configuration file at: /home/ubuntu/.cephdeploy.conf
2015-08-13T22:41:51.125 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.cli][INFO  ] Invoked (1.5.25): /usr/bin/ceph-deploy rgw create magna087
2015-08-13T22:41:51.127 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][DEBUG ] Deploying rgw, cluster ceph hosts magna087:rgw.magna087
2015-08-13T22:41:51.162 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] connection detected need for sudo
2015-08-13T22:41:51.183 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] connected to host: magna087
2015-08-13T22:41:51.199 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] detect platform information from remote host
2015-08-13T22:41:51.206 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] detect machine type
2015-08-13T22:41:51.220 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][INFO  ] Distro info: Red Hat Enterprise Linux Server 7.1 Maipo
2015-08-13T22:41:51.225 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][DEBUG ] remote host will use sysvinit
2015-08-13T22:41:51.226 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][DEBUG ] deploying rgw bootstrap to magna087
2015-08-13T22:41:51.227 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] write cluster configuration to /etc/ceph/{cluster}.conf
2015-08-13T22:41:51.237 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] create path recursively if it doesn't exist
2015-08-13T22:41:51.238 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][INFO  ] Running command: sudo ceph --cluster ceph --name client.bootstrap-rgw --keyring /var/lib/ceph/bootstrap-rgw/ceph.keyring auth get-or-create client.rgw.magna087 osd allow rwx mon allow rw -o /var/lib/ceph/radosgw/ceph-rgw.magna087/keyring
2015-08-13T22:41:51.583 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][INFO  ] Running command: sudo service ceph-radosgw start
2015-08-13T22:41:51.651 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] Starting ceph-radosgw (via systemctl):  [FAILED]
2015-08-13T22:41:51.653 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][WARNING] Failed to issue method call: Unit ceph-radosgw.service failed to load: No such file or directory.
2015-08-13T22:41:51.654 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][ERROR ] RuntimeError: command returned non-zero exit status: 6
2015-08-13T22:41:51.655 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][ERROR ] Failed to execute command: service ceph-radosgw start
2015-08-13T22:41:51.656 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy][ERROR ] GenericError: Failed to create 1 RGWs
2015-08-13T22:41:51.657 INFO:teuthology.orchestra.run.magna087.stderr:


Version-Release number of selected component (if applicable):
1.5.25-1.el7cp/ 0.94.1-17.el7cp


How reproducible:
1/1 Run

Steps to Reproduce:
Run ceph-deploy smoke test

Actual results:


2015-08-13T22:41:50.895 INFO:teuthology.orchestra.run.magna087:Running: 'cd ~/cdtest ; ceph-deploy rgw create magna087'
2015-08-13T22:41:51.115 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.conf][DEBUG ] found configuration file at: /home/ubuntu/.cephdeploy.conf
2015-08-13T22:41:51.125 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.cli][INFO  ] Invoked (1.5.25): /usr/bin/ceph-deploy rgw create magna087
2015-08-13T22:41:51.127 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][DEBUG ] Deploying rgw, cluster ceph hosts magna087:rgw.magna087
2015-08-13T22:41:51.162 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] connection detected need for sudo
2015-08-13T22:41:51.183 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] connected to host: magna087
2015-08-13T22:41:51.199 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] detect platform information from remote host
2015-08-13T22:41:51.206 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] detect machine type
2015-08-13T22:41:51.220 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][INFO  ] Distro info: Red Hat Enterprise Linux Server 7.1 Maipo
2015-08-13T22:41:51.225 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][DEBUG ] remote host will use sysvinit
2015-08-13T22:41:51.226 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][DEBUG ] deploying rgw bootstrap to magna087
2015-08-13T22:41:51.227 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] write cluster configuration to /etc/ceph/{cluster}.conf
2015-08-13T22:41:51.237 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] create path recursively if it doesn't exist
2015-08-13T22:41:51.238 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][INFO  ] Running command: sudo ceph --cluster ceph --name client.bootstrap-rgw --keyring /var/lib/ceph/bootstrap-rgw/ceph.keyring auth get-or-create client.rgw.magna087 osd allow rwx mon allow rw -o /var/lib/ceph/radosgw/ceph-rgw.magna087/keyring
2015-08-13T22:41:51.583 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][INFO  ] Running command: sudo service ceph-radosgw start
2015-08-13T22:41:51.651 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][DEBUG ] Starting ceph-radosgw (via systemctl):  [FAILED]
2015-08-13T22:41:51.653 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][WARNING] Failed to issue method call: Unit ceph-radosgw.service failed to load: No such file or directory.
2015-08-13T22:41:51.654 INFO:teuthology.orchestra.run.magna087.stderr:[magna087][ERROR ] RuntimeError: command returned non-zero exit status: 6
2015-08-13T22:41:51.655 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy.rgw][ERROR ] Failed to execute command: service ceph-radosgw start
2015-08-13T22:41:51.656 INFO:teuthology.orchestra.run.magna087.stderr:[ceph_deploy][ERROR ] GenericError: Failed to create 1 RGWs
2015-08-13T22:41:51.657 INFO:teuthology.orchestra.run.magna087.stderr:
2015-08-13T22:41:51.671 ERROR:teuthology.contextutil:Saw exception from nested tasks
Traceback (most recent call last):
  File "/home/vasu/ds/teuthology/teuthology/contextutil.py", line 28, in nested
    vars.append(enter())
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/ceph-qa-suite_rh130/tasks/ceph_deploy.py", line 532, in cli_test
    execute_cdeploy(admin,rgw_create,path)
  File "/home/teuthworker/src/ceph-qa-suite_rh130/tasks/ceph_deploy.py", line 465, in execute_cdeploy
    raise RuntimeError ("failed during ceph-deploy cmd: {cmd} , ec={ec}".format(cmd=cmd,ec=ec))
RuntimeError: failed during ceph-deploy cmd: rgw create magna087 , ec=1
2015-08-13T22:41:51.673 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/vasu/ds/teuthology/teuthology/run_tasks.py", line 56, in run_tasks
    manager.__enter__()
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/ceph-qa-suite_rh130/tasks/ceph_deploy.py", line 572, in single_node_test
    lambda: cli_test(ctx=ctx,config=config),
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/vasu/ds/teuthology/teuthology/contextutil.py", line 28, in nested
    vars.append(enter())
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/ceph-qa-suite_rh130/tasks/ceph_deploy.py", line 532, in cli_test
    execute_cdeploy(admin,rgw_create,path)
  File "/home/teuthworker/src/ceph-qa-suite_rh130/tasks/ceph_deploy.py", line 465, in execute_cdeploy

Expected results:



Additional info:
Comment 2 Travis Rhoden 2015-08-14 12:34:02 EDT
did the node that you are trying to create an RGW on have RGW installed first with "ceph-deploy install --rgw" ?

For downstream, we document to install the daemons separately (since the come from different repos), so RGW shouldn't be installed by default unless you do it explicitly.
Comment 3 Vasu Kulkarni 2015-08-14 12:51:42 EDT
rgw has been installed, this test was working before, http://magna002.ceph.redhat.com/vasu-2015-08-13_22:39:17-rh-ceph-1.3.0.b17-smoke/819897/teuthology.log
Comment 4 Federico Lucifredi 2015-12-10 17:56:32 EST
Vasu, is this still a problem?
Comment 5 Alan Bishop 2016-06-16 13:59:15 EDT
I wonder if this is related to a similar problem I encountered when deploying an RGW using ceph-ansible. See https://github.com/ceph/ceph-ansible/issues/843, where I traced the problem to what I believe is a deficiency in the ceph-radosgw RPM's postinstall scriptlet. In short, it isn't running chkconfig, which is what causes systemd to create it's unit file.

Note You need to log in before you can comment on or make changes to this bug.