Bug 1253791 - bluray test fails with dvd+rw-mediainfo /dev/sr0
bluray test fails with dvd+rw-mediainfo /dev/sr0
Status: CLOSED NOTABUG
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: brose
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 13:37 EDT by Brian Brock
Modified: 2015-08-14 14:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 14:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2015-08-14 13:37:29 EDT
The bluray test fails with the error:
Error: could not verify the media type.
"dvd+rw-mediainfo /dev/sr0 " has output on stderr

redhat-certification-1.0-20150813.el6.noarch
redhat-certification-hardware-1.6.6-20150813.el6.noarch

happens reliably.

Steps to Reproduce:
1. launch the bluray test
2. follow the instructions for testing
3. use new blank media (tested with bd-r media)
3. watch for error messages



Actual results:
interactive certification
sr0
/devices/pci0000:00/0000:00:1f.2/host1/target1:0:0/1:0:0:0/block/sr0
FAIL
 
 
  Your device /dev/sr0 supports bd-re, bd-r, bd
 
response: False
response: bd-r
 
  Your drive /dev/sr0 supports bd-r
  You need to prepare a new bd-r disc to run this test.
response:
 
response:
  Tray closed ...
 
  Verifiying media type: bd-r ...
Error: could not verify the media type.
"dvd+rw-mediainfo /dev/sr0 " has output on stderr
 
 

Expected results:
successful, passing test.  The hardware & media should be good.

Additional info:
Thu Aug 13 05:24:17
root@hp-z230-02.lab.eng.rdu.redhat.com ~
# dvd+rw-mediainfo /dev/sr0
INQUIRY:                [PIONEER ][BD-RW   BDR-209D][1.10]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         41h, BD-R SRM
 Media ID:               RITEK/BR3
 Current Write Speed:   10.0x4495=44950KB/s
 Write Speed #0:        10.0x4495=44950KB/s
 Write Speed #1:        8.0x4495=35960KB/s
 Write Speed #2:        6.0x4495=26970KB/s
 Write Speed #3:        4.0x4495=17980KB/s
 Write Speed #4:        2.0x4495=8990KB/s
 Speed Descriptor#0:    00/12219391 R@10.0x4495=44950KB/s W@10.0x4495=44950KB/s
 Speed Descriptor#1:    00/12219391 R@8.0x4495=35960KB/s W@8.0x4495=35960KB/s
 Speed Descriptor#2:    00/12219391 R@6.0x4495=26970KB/s W@6.0x4495=26970KB/s
 Speed Descriptor#3:    00/12219391 R@4.0x4495=17980KB/s W@4.0x4495=17980KB/s
 Speed Descriptor#4:    00/12219391 R@2.0x4495=8990KB/s W@2.0x4495=8990KB/s
:-[ READ BD SPARE INFORMATION failed with SK=5h/MEDIUM NOT FORMATTED]: Wrong medium type
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ FORMAT CAPACITIES:
 unformatted:           12219392*2048=25025314816
 00h(3000):             11826176*2048=24220008448
 32h(0):                11826176*2048=24220008448
 32h(0):                5796864*2048=11871977472
 32h(0):                12088320*2048=24756879360
READ TRACK INFORMATION[#1]:
 Track State:           invisible incremental
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           12219392*2KB
 Track Size:            12219392*2KB
READ CAPACITY:          0*2048=0
Comment 1 brose 2015-08-14 14:52:41 EDT
This is not a bug, but desired behavior.  The drive should be tested for the highest level of functionality, which in this case means bd-re.

from the guide:

"The test suite always attempts to schedule the most advanced media tests first in accordance with the rules in the Policy Guide, which requires testing read, write and erase functionality when all are present."

and

"If the drive is not capable of rewrite operations but it does have write-once capabilities for a disc format, the test suite schedules a write-once media test."

Note You need to log in before you can comment on or make changes to this bug.